Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31521 - [slim] note: last fix labelled as "glib-segfault" is actually a bug in slim

Attached to Project: Arch Linux
Opened by Fabien COUTANT (fcoutant) - Thursday, 13 September 2012, 07:25 GMT
Last edited by Allan McRae (Allan) - Friday, 16 November 2012, 14:03 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Roman Kyrylych (Romashka)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I just happened to check what changed in this slim version, and looked at the "fix-glibc*" patch;
The fact that one has to allocate one more cell in the child_env array is not due to glibc but to a context line that fortunately appears at the end of the patch file:
child_env[n] = NULL;
This explicitly writes beyond the end of the previously allocated array size (remember C/C++ arrays start counting at 0), thus a segfault in this case was perfectly legitimate and not a bug in glibc.

Additional info:
* package version(s)
slim 1.3.4-3
* config and/or log files etc.
in package build files: fix-glibc-segfault*.patch

Steps to reproduce:
n/a
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 16 November 2012, 14:03 GMT
Reason for closing:  Fixed
Comment by Jelle van der Waa (jelly) - Thursday, 13 September 2012, 09:19 GMT
Please report it upstream
Comment by Tobias Powalowski (tpowa) - Thursday, 13 September 2012, 12:33 GMT
Sorry I named it like this, there was no name given in the bug report.

Loading...