Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#31495 - [linux] 3.5.3: Black screen (both CMD and X) when using this kernel version

Attached to Project: Arch Linux
Opened by Tomasz Jankowski (goofy) - Tuesday, 11 September 2012, 16:33 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 05 November 2012, 15:14 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


After updating to latest kernel release my screen goes black every time I boot laptop. Just after first few lines of kernel init logs. Then screen goes black, I can control LCD brightness but I don't see anything. Even if I switch to console I don't see anything.

I'm able to start computer "somehow normal" by adding "i915.modeset=0" to kernel init parameters via GRUB. Then I see CMD in low resolution.

Now I downgraded to Linux v3.4.8 and everything works fine with lates Intel driver.

Additional info:
* xf86-video-intel 2.20.7-1
* linux 3.5.3-1 (not working)
* linux 3.4.8 (working)
* X log:
* dmesg output:

Steps to reproduce:
Get laptop such as mine (Dell Lattitude E5510) update it to latest version of packages and reboot.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 05 November 2012, 15:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.6.3
Comment by Etienne Doms (Smod) - Wednesday, 12 September 2012, 17:19 GMT

I had the same problem, but this can be solved by loading the "i915" module in an initrd instead of waiting for udev to do it.

On a regular ArchLinux system, just add "i915" to MODULES in /etc/mkinitcpio.conf and then rebuild the initrd with "mkinitcpio -p linux".
Comment by Tomasz Jankowski (goofy) - Wednesday, 12 September 2012, 17:22 GMT
I have MODULES set to "intel_agp i915" for e very long time.
Comment by saber (sabery) - Friday, 14 September 2012, 14:50 GMT
I had the same issue with you.
And after check your description, I found we have the same laptops.
Comment by Thomas Bächler (brain0) - Friday, 14 September 2012, 14:57 GMT
Did you report this problem to the intel guys? Either the kernel bugzilla or bugzilla will do fine. They did some restructuring between 3.4 and 3.5, so they might know what the problem is.
Comment by Tomasz Jankowski (goofy) - Friday, 14 September 2012, 22:31 GMT
Not yet. Now after you said this, I'm going to report this to Intel tomorrow. I'll attach link to report as soon as it will be ready.
Comment by Tomasz Jankowski (goofy) - Saturday, 15 September 2012, 12:56 GMT Comment by Christoph RIssner (resi) - Wednesday, 19 September 2012, 20:11 GMT
I had this problem after the update to linux 3.4.9 on my eeepc, adding acpi_osi=Linux solved my issue. I just upgraded to linux 3.5.4 and it still works.

% lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
Comment by saber (sabery) - Thursday, 20 September 2012, 03:53 GMT
Maybe we had different issues. I'm using 3.4.9 now and can't upgrade to 3.5.3, even with kernal argument acpi_osi=Linux.

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
Comment by Greg (dolby) - Tuesday, 16 October 2012, 09:01 GMT Comment by Tobias Powalowski (tpowa) - Tuesday, 16 October 2012, 09:23 GMT
At the moment only in 3.7 tree.