Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31471 - [zsnes] lib32-alsa-lib need to sound

Attached to Project: Community Packages
Opened by Pablo Lezaeta (Jristz) - Saturday, 08 September 2012, 18:17 GMT
Last edited by Laurent Carlier (lordheavy) - Wednesday, 12 September 2012, 13:47 GMT
Task Type Support Request
Category Packages: Multilib
Status Closed
Assigned To Florian Pritz (bluewind)
Sven-Hendrik Haase (Svenstaro)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I intall this one with no lib32-alsa related packages and not have any sound
beffore I install lib32-alsa-lib and magicaly the sound beffore restart zsnes in sound

you can add lib32-alsa-lib as an opd dep or an dep to zsnes??

Additional info:
* zsnes and lib32-alsa-lib
* default

Steps to reproduce:
install zsnes with no lib32-alsa related packages and play a game and try to find sounds
install lib32-alsa-lib and restart zsnes and try to sound more sounds
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Wednesday, 12 September 2012, 13:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  zsnes-1.51-16
Comment by Laurent Carlier (lordheavy) - Saturday, 08 September 2012, 22:01 GMT
If it works, but without sound, then it's an optional dependency
Comment by Pablo Lezaeta (Jristz) - Saturday, 08 September 2012, 22:20 GMT
I suggest as optdep lib32-alsa-lib as a solution (is enought the lib32-alsa-lib) for sound support and without them work but with no sound
and is borring with no sound

the optdep for lib32-alsa-lib is enugh for sound
Comment by Florian Pritz (bluewind) - Monday, 10 September 2012, 19:55 GMT
IMHO users should install lib32 alsa/pulse package if the use alsa/pulse in the 64bit system without that dep, but I won't object if someone adds an optdep. I do not like a hard dependency though unless the package only support alsa/pulse and won't work/be useful without it.

I've assigned Sven and Laurent since they handled a similar bug ~1 month ago.
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 12 September 2012, 05:08 GMT
I'd be fine with an optdep.
Comment by Laurent Carlier (lordheavy) - Wednesday, 12 September 2012, 08:08 GMT
optdep is the best solution, it follow the way of wine and dwarffortress packages

Loading...