Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31469 - [pulseaudio] master volume at zero and muted when pulseaudio starts

Attached to Project: Arch Linux
Opened by Frank Wilson (fajwilson) - Saturday, 08 September 2012, 16:16 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 12 December 2012, 05:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

This bug has been reported upstream [1].

Pulseaudio version: pulseaudio 2.1

This is issue was previously reported and discussed on the mailinglist back in
June [2].

I have since updated my arch linux system and it is still affected.

I reran the same test I described earlier and I got the same results.

Problem description:

I have noticed that the master channel volume is set to zero and muted
when I login to gnome3 on my arch linux vm.

After looking at various things such as storing and restoring alsa
settings, I determined the volume settings get changed when pulseaudio
starts.


[1] https://bugs.freedesktop.org/show_bug.cgi?id=54673
[2] http://lists.freedesktop.org/archives/pulseaudio-discuss/2012-June/013710.html

Additional info:
* package version(s)

Pulseaudio 2.1

* config and/or log files etc.

amixer.org
amixer.pulse
pulse_syslog.log
(see attached)

Steps to reproduce:


To fully isolate the cause I did a test with a bare non-graphical
login (no gnome session, no login manager, no other sound program).

Test trace (fresh as of 08/09/2012)

[frank@basilica ~]$ date
Sat 8 Sep 16:33:28 BST 2012
[frank@basilica ~]$ alsactl init 0
Found hardware: "ICH" "SigmaTel STAC9700,83,84" "AC97a:83847600" "0x8086"
"0x000
0"
Hardware is initialized using a generic method
[frank@basilica ~]$ speaker-test

<<<<< CAN HEAR SOUND >>>>>

[frank@basilica ~]$ amixer -c0 > amixer.org
[frank@basilica ~]$ pulseaudio --start -vvvvv
I: [pulseaudio] main.c: Daemon startup successful.
[frank@basilica ~]$ speaker-test

<<<<< CANNOT HEAR SOUND! >>>>

[frank@basilica ~]$ amixer -c0 > amixer.pulse
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 12 December 2012, 05:12 GMT
Reason for closing:  Upstream
Additional comments about closing:  https://bugs.freedesktop.org/show_bug.cg i?id=54673
Comment by Jan Alexander Steffens (heftig) - Saturday, 08 September 2012, 16:59 GMT
When it starts, PulseAudio will restore the device's volume to what it saved. That's a feature, not a bug.

You can reset the saved volumes by deleting the device volume database ~/.pulse/*-device-volumes.tdb .

While using PulseAudio, make sure to alter the volume using a pulse mixer, e.g. gnome-control-center or pavucontrol.
Comment by Frank Wilson (fajwilson) - Sunday, 09 September 2012, 09:45 GMT
I didn't realise pulseaudio had its own mixer settings!

I had tried playing around with pavucontrol and gnome-control-center but it did not seem to help.

After your comment I had another go with pavucontrol and started clicking everything and suddenly I start getting sound again.

I reset my .pulse dir to find out what made the difference (delete .pulse from console session and reboot, login to gnome).

It turns out I have to switch output "connector" (in gnome) or "port" (pavucontrol) from "Analog Mono" to "LFE on seperate mono output" (whatever that is!)

Now pulseaudio seems to keep the "good" setting where sound can be heared. It seems that after changing this one setting, the master channel that was zeroed and muted is now maxed and unmuted.

Comment by Jan Alexander Steffens (heftig) - Sunday, 09 September 2012, 16:00 GMT
So it appears the default settings for your card aren't sane?

What's the output of "pacmd list"?

You could raise a bug about this upstream ( https://bugs.freedesktop.org/ ).
Comment by Greg (dolby) - Sunday, 09 September 2012, 16:44 GMT
Theres a link to the upstream bugzilla on the original report above: https://bugs.freedesktop.org/show_bug.cgi?id=54673

Im having the same issue, so here is my pacmd list output.
   pacmd (17.7 KiB)

Loading...