Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31405 - [oss, libflashsupport-oss] soundon creates a conflicting link to 32-bit libflashsupport

Attached to Project: Community Packages
Opened by Old User New ID (u2012) - Tuesday, 04 September 2012, 00:25 GMT
Last edited by Kyle Keen (keenerd) - Wednesday, 25 September 2013, 11:38 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

the soundon script (invoked by `rc.d start oss`) has the lines:

###############
if ! test -f /usr/lib/libflashsupport.so && test -f $OSSLIBDIR/lib/libflashsupport_32.so
then
ln -sf $OSSLIBDIR/lib/libflashsupport_32.so /usr/lib/libflashsupport.so
fi
###############

This causes 2 problems:
1) The link will cause a conflict with libflashsupport-oss (AFAICT).
2) The library linked to has the wrong arch in x86_64 systems (tested and confirmed).

Additional info:

* package version(s)
oss 4.2_2006-4

* config and/or log files etc.
/usr/sbin/soundon
Lines 316-319

Steps to reproduce:
pacman -S oss
rc.d start oss
/bin/ls -l /usr/lib/libflashsupport.so
This task depends upon

Closed by  Kyle Keen (keenerd)
Wednesday, 25 September 2013, 11:38 GMT
Reason for closing:  Won't fix
Additional comments about closing:  OSS has been moved to AUR.
Comment by Kyle Keen (keenerd) - Saturday, 03 November 2012, 03:49 GMT
Just to confirm, this is still an issue with 4.2_2007-1?
Comment by Old User New ID (u2012) - Thursday, 22 November 2012, 21:37 GMT
It is still an issue.
Comment by Kyle Keen (keenerd) - Friday, 23 November 2012, 16:54 GMT
I can not reproduce this issue.

What package is providing the libflashsupport_32.so file? It is not in multilib/lib32-libflashsupport or libflashsupport-oss. Without that file, there is no bug.
Comment by Old User New ID (u2012) - Wednesday, 28 November 2012, 10:37 GMT
It's built during post_install()

Check out /usr/lib/oss/build/install.sh
Comment by Philip (nuc) - Thursday, 07 February 2013, 17:29 GMT
Yeah I had some troubles with that issue when switching to latest glibc/filesystem: https://bbs.archlinux.org/viewtopic.php?pid=1223438#p1223438
read from post #7 onward
Comment by Philip (nuc) - Friday, 05 April 2013, 23:59 GMT
I think the problem might be connected to the fact that OSSv4 actually has libflashsupport integrated out of the box http://www.4front-tech.com/wiki/index.php/Configuring_Applications_for_OSSv4#Adobe_Flash
>"OSSv4.1 tries to install a fitting libflashsupport automatically. However, some distros prefer removing libflashsupport from the package, using a separate package for it."

Also I see Arch didn't use a seperate package before, because the (outdated) wiki says:
>"Arch: libflashsupport should be included in the oss package. If you installed OSS manually or the included libflashsupport fails, read on.

Maybe it is still being built by mistake?

Loading...