Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31385 - [gimp-ufraw] Please enable all features for ufraw

Attached to Project: Community Packages
Opened by Martin Sugioarto (cinek) - Sunday, 02 September 2012, 09:11 GMT
Last edited by Alexander F Rødseth (xyproto) (trontonic) - Friday, 01 February 2013, 16:43 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Alexander F Rødseth (xyproto) (trontonic)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

ufraw is not really useful, when all its features are disabled.

Missing features are:
- lensfun
- contrast support
- fits (not sure about this one, but I don't see dependencies on cfitsio)

Please add the configure switches to the PKGBUILD and update the dependencies.

Additional info:
* affected version 0.18-5

Steps to reproduce:
Open a RAW image with Gimp and take a look at the missing features (that every other distribution has). ;)
This task depends upon

Closed by  Alexander F Rødseth (xyproto) (trontonic)
Friday, 01 February 2013, 16:43 GMT
Reason for closing:  Fixed
Comment by Uli (Army) - Sunday, 02 September 2012, 14:50 GMT
Makes one wonder why those features need to be activated manually. Maybe these features aren't in a state where it's safe to use them.
Comment by Martin Sugioarto (cinek) - Sunday, 02 September 2012, 17:55 GMT
The website says that lensfun is not ready to use. Despite this comment (the author is a perfectionist!), I highly recommend to add lensfun to the default features, because it will do lots of harm not considering the lens corrections when converting pictures from RAW formats.

It appears that the author of the tool tried to minimize the dependency requirements, so that the packagers don't get problems. But on other distributions you see all the features enabled usually (or at least available as an option).

Extra information: I migrated from FreeBSD and ufraw looks a bit lightweight on Arch for me and now even increasingly annoying, because I really need many features for my photos.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Saturday, 08 September 2012, 23:50 GMT
gimp-ufraw is an orphan. Assigning to last packager.
Comment by Martin Sugioarto (cinek) - Sunday, 09 September 2012, 09:18 GMT
Since there is no package maintainer, I tried to make a patch. Please review it, I have no experience with this. It seems to build, install and function correctly (recognizes my camera lens!).

One further remark:
- build depends on cinepaint and I explicitly enabled cinepaint (I don't know if this is correct)
Comment by Alexander F Rødseth (xyproto) (trontonic) - Sunday, 09 September 2012, 12:20 GMT
@cinek, thanks for the patch. Please submit it upstream to the gimp-ufraw developers.

@ise, could you please move this package to [community] (unless you don't wish to maintain it). Last packager (Snowman) doesn't seem to be interested, and you maintain the gimp package. Thanks.
Comment by Martin Sugioarto (cinek) - Monday, 10 September 2012, 18:34 GMT
This is not a patch for gimp-ufraw. This is a patch for your PKGBUILD file in the ArchLinux distribution. I made a diff against the Arch Linux packages repo.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 10 September 2012, 20:47 GMT
Ok, thanks. Changing the category.
Comment by Jakob Steltner (trurl23) - Saturday, 17 November 2012, 00:10 GMT
The patch works fine. Opened RAW-file in GIMP, my lens was also correctly detected by ufraw.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 28 January 2013, 10:00 GMT
Adopted gimp-ufraw. I'll look at this issue.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Friday, 01 February 2013, 16:42 GMT
Updated the package in [community]. Thanks Martin Sugioarto, added your name as a contributor to the PKGBUILD.

Loading...