Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31384 - [linux] 3.5.3 ThinkPad X220 Tablet touch screen no longer works properly with wacom module

Attached to Project: Arch Linux
Opened by Nathan Acks (necopinus) - Saturday, 01 September 2012, 23:16 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 07 October 2012, 06:58 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Distribution: Arch Linux
Kernel version: 3.5.3

Under kernel 3.4.9 the touch screen on my ThinkPad X220 Tablet worked flawlessly and without configuration; however, after updating to 3.5.3 the touch screen is no longer responsive, and does not appear to be properly detected.

Output of lsusb shows my touch screen just fine:

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 008: ID 04e8:681c Samsung Electronics Co., Ltd Galaxy Portal/Spica/S
Bus 001 Device 003: ID 1a40:0201 Terminus Technology Inc. FE 2.1 7-port Hub
Bus 001 Device 004: ID 04f2:b217 Chicony Electronics Co., Ltd Lenovo Integrated Camera (0.3MP)
Bus 002 Device 005: ID 056a:0094 Wacom Co., Ltd
Bus 001 Device 005: ID 195d:1009 Itron Technology iONE
Bus 001 Device 006: ID 045e:00b4 Microsoft Corp. Digital Media Keyboard 1.0A
Bus 001 Device 007: ID 1a40:0201 Terminus Technology Inc. FE 2.1 7-port Hub

*Most* of the time the wacom kernel module loads correctly, though I've noticed that it isn't present in the output of lsmod | grep wacom about 1 boot out of 4.

wacom 41218 0
usbcore 147434 7 uas,wacom,uvcvideo,usb_storage,ehci_hcd,usbhid,cdc_acm

When the wacom kernel module is loaded, I see something like the following lines in dmesg | grep "[w|W]acom":

[ 20.382806] input: Wacom ISDv4 E6 Pen as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.0/input/input9
[ 20.388085] input: Wacom ISDv4 E6 Finger as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.1/input/input10
[ 20.389276] usbcore: registered new interface driver wacom

However, by the time my machine finishes booting the path /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.0/input/input9 doesn't exist!

Booting into an Ubuntu live CD (kernel version 3.2) results in a properly working touch screen, as does downgrading to kernel version 3.4.9. The only difference I can find between the working and non-working configurations is the presence of /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.0/input/input9 (or the equivalent, corresponding to the output of dmesg).

Forum posts dealing with this issue:

https://bbs.archlinux.org/viewtopic.php?pid=1154414 (Mine)
https://bbs.archlinux.org/viewtopic.php?id=147887 (another user)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 07 October 2012, 06:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.5.5-1
Comment by Nathan Acks (necopinus) - Saturday, 01 September 2012, 23:17 GMT Comment by Nathan Acks (necopinus) - Friday, 07 September 2012, 05:07 GMT
Recompiling the 3.5.3-1 kernel using the patch from http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commitdiff;h=ea2e60244573a9204c8cee9b4fb181106784c617 appears to resolve the issue.
Comment by Nathan Acks (necopinus) - Wednesday, 19 September 2012, 04:41 GMT
Apparently the fix did not make it into 3.5.4 from upstream... :-(
Comment by Nathan Acks (necopinus) - Saturday, 22 September 2012, 04:52 GMT
Actually, I'm not sure if the patch made it in or not. Certainly the problem is persisting for me under 3.5.4-1. Moreover, applying the linked patch and recompiling no longer resolves the issue. :'(
Comment by Egon Geerardyn (egeerardyn) - Saturday, 22 September 2012, 07:53 GMT
@Nathan: have you also tried reflashing the tablet firmware of the X220T available on http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/fwdigi01.exe ? I had to do that after downgrading from 3.5 to 3.4 to solve this (I haven't recompiled the kernel to fix this). Just FYI, for me it works when I flash the firmware from within VirtualBox, so I didn't need a dualboot Windows.
Comment by Nathan Acks (necopinus) - Saturday, 22 September 2012, 14:01 GMT
@egeerardyn: I had not tried reflashing the firmware, though oddly enough I discovered that the touchscreen was working this morning using a patched 3.5.4. Apparently (at least on my system) I have to do a suspend/resume cycle. Weird.
Comment by S Platz (paalsteek) - Monday, 24 September 2012, 12:16 GMT
Apparently you have to shutdown/reboot or suspend/resume cycle your laptop in order to get the wacom working. I read somewhere that the hardware is not correctly initialized without the driver so some reinitialization is needed. It may be necessary to do a cold boot as a hot reboot does not reset the hardware. Would be great to see the patch in the next kernel.
Comment by Nathan Acks (necopinus) - Sunday, 07 October 2012, 01:32 GMT
Issue appears to be resolved in 3.5.5-1.

Loading...