Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31362 - [xf86-video-nouveau] flightgear crash when loading scenery

Attached to Project: Community Packages
Opened by Vincenzo (KinG-InFeT) - Friday, 31 August 2012, 14:49 GMT
Last edited by Sergej Pupykin (sergej) - Saturday, 29 December 2012, 10:08 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Andreas Radke (AndyRTR)
Sergej Pupykin (sergej)
Ionut Biru (wonder)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
run flightgear and crash

Additional info:
* package version(s) = 2.8.0

LOG:

KI266 dme indicator #0 initialized
loading scenario 'nimitz_demo'
PNG lib warning : Interlace handling should be turned on when using png_read_image
PNG lib warning : Interlace handling should be turned on when using png_read_image
Initializing Nasal Electrical System
join_values_nofail:398 - failed to coalesce values
join_values_nofail:398 - failed to coalesce values
fgfs: nv50_pc.h:351: nv_alloc_instruction: Assertion `pc->num_instructions < 2048' failed.
Aborted

Steps to reproduce:

1) install
2) run
3) loading scenery
4) CRASH
This task depends upon

Closed by  Sergej Pupykin (sergej)
Saturday, 29 December 2012, 10:08 GMT
Reason for closing:  Upstream
Comment by Alexander F. Rødseth (xyproto) - Saturday, 01 September 2012, 21:37 GMT
I see "nv50" is mentioned. Could you please try with the open source nvidia drivers if you're using the closed source blobs, or try with the closed source blobs if you are using the open source drivers?
Comment by Vincenzo (KinG-InFeT) - Sunday, 02 September 2012, 00:41 GMT
i use the open-source driver nouveau
Comment by Alexander F. Rødseth (xyproto) - Sunday, 02 September 2012, 09:20 GMT
Would you be willing to try with the binary Nvidia drivers, just to try and pinpoint where the problem lies? Thanks
Comment by Vincenzo (KinG-InFeT) - Sunday, 02 September 2012, 11:25 GMT
I installed the nvidia closed-source, and indeed the application starts and stops as before, but there are some problems with the graphics of the game that comes out at times ....

leaves little or nothing in the log:
KI266 dme indicator #0 initialized
loading scenario 'nimitz_demo'
PNG lib warning : Interlace handling should be turned on when using png_read_image
PNG lib warning : Interlace handling should be turned on when using png_read_image
Initializing Nasal Electrical System
KAP140 power up
Loading local weather routines...

at most a few problem with the PNG library?
Comment by Alexander F. Rødseth (xyproto) - Sunday, 02 September 2012, 20:41 GMT
Thanks for testing this out, Vincenzo. The PNG warnings and/or problems with how the graphics looks can be reported to the flightgear upstream at the forum (http://www.flightgear.org/forums), irc(http://wiki.flightgear.org/IRC) or the mailing list (http://wiki.flightgear.org/Mailing_list). This is how they prefer the bugs to be reported, according to http://wiki.flightgear.org/index.php/FAQ#Why_won.27t_FlightGear_compile.3F

Also, the flightgear webpage specifically states that "Linux users with nVidia cards should make sure you have the latest drivers from nVidia.". One interpretation of this is that open source nvidia drivers are not supported.

This, which may or may not be relevant, is also from their webpage: "FreeGlut 2.4.0 has a critical bug that crashes FlightGear. If you plan to use FreeGlut instead of SDL you will need to upgrade to FreeGlut-2.6.0.".

Since this seems to be a "nv50" problem, I'll reassign this bug to xf86-video-nouveau. It may be a bug for the specific combination of nouveau and flightgear, though.
Comment by Greg (dolby) - Monday, 19 November 2012, 08:14 GMT
Please report this upstream to the nouveau developers.
Comment by Vincenzo (KinG-InFeT) - Monday, 19 November 2012, 14:40 GMT
Open a new bug in nouveau bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=57278

Loading...