Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31350 - [xf86-input-evdev] mtdev support breaks xf86-input-evdev

Attached to Project: Arch Linux
Opened by Lachlan (padfoot) - Friday, 31 August 2012, 07:43 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 28 December 2012, 18:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: building xf86-input-evdev with mtdev support breaks 'Evdev Axis Inversion' and 'Evdev Axes Swap' and touch events. Please see upstream bug https://bugs.freedesktop.org/show_bug.cgi?id=53669 for details and progress.


Additional info:
Occurs in upgrade from xf86-input-evdev-2.7.2 to xf86-input-evdev-2.7.3 due to 2.7.3 being built with mtdev support


Steps to reproduce:
Install xf86-input-evdev-2.7.3
Modify input axes with: xinput set-prop <device id> 'Evdev Axis Inversion' 1 0
xinput set-prop <device id> 'Evdev Axes Swap' 1
Output of :xinput list-props <device id> shows changed input axes, yet input axes have not changed. All input remains as if the device properties were not modified.

Solution:
Build xf86-input-evdev-2.7.3 without mtdev support.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 28 December 2012, 18:11 GMT
Reason for closing:  Upstream
Additional comments about closing:  this is either a bug in mtdev or in the closed egalax driver. you will be pretty much on your own for now. there's nothing we can do downstream. use abs to rebuild without mtdev support.
Comment by David López (David López) - Saturday, 01 September 2012, 14:35 GMT
Hi. I have an ekoore perl tablet (wetab, exopc) with an egalax touchscreen. With 2.7.3 evdev driver I suffer all the issues that Padfoot comment in https://bugs.freedesktop.org/show_bug.cgi?id=53669: random focus, scroll not working with easystroke, evdev axis don't rotate touchscreen. Downgrading to 2.7.2 (from the snapshots in ARM) all these problems disappear. I believe, as Padfoot said, that building 2.7.3 driver without mtdev support is a solution

PD: I suffered the problems in Lubuntu 12.04 precise. I don't know if ubuntu's xserver-xorg-input-evdev was built with mtdev enabled or disabled.

Loading...