Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31341 - [ifplug] missing file /etc/ifplugd/ifplugd.action

Attached to Project: Arch Linux
Opened by Krzysztof Grygiencz (kfgz) - Thursday, 30 August 2012, 12:31 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 01 September 2012, 14:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

ifplug by default runs this script /etc/ifplugd/ifplugd.action but there is no such file in iflpug package. Instead there is /etc/ifplugd/netcfg.action

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:

ifplug -n

output:

ifplugd 0.28 initializing.
Using interface eth0/00:22:15:86:0E:01 with driver <sky2> (version: 1.30)
Using detection mode: SIOCETHTOOL
Initialization complete, link beat not detected.
Link beat detected.
Executing '/etc/ifplugd/ifplugd.action eth0 up'.
Program execution failed, return value is 1.
Exiting.


Correct execution should look like this

ifplug -n -r /etc/ifplugd/netcfg.action


output:

ifplugd 0.28 initializing.
Using interface eth0/00:22:15:86:0E:01 with driver <sky2> (version: 1.30)
Using detection mode: SIOCETHTOOL
Initialization complete, link beat detected.
Executing '/etc/ifplugd/netcfg.action eth0 up'.
client: up
client: loading myhost
client: :: myhost up [done]
Program executed successfully.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 01 September 2012, 14:51 GMT
Reason for closing:  Not a bug
Comment by Matthias Dienstbier (fs4000) - Thursday, 30 August 2012, 13:43 GMT
This is intended! You are supposed to write your own action script. If you want to use netcfg then ignore all the ifplugd stuff. But there is a bug in netcfg:  FS#31340 

Loading...