Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#31334 - Long start for 'systemd-vconsole-setup.service'

Attached to Project: Arch Linux
Opened by ajes (ajes) - Wednesday, 29 August 2012, 19:07 GMT
Last edited by Gaetan Bisson (vesath) - Sunday, 09 September 2012, 16:03 GMT
Task Type General Gripe
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture i686
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No


systemd-vconsole-setup.service has starting very long. It takes 2600ms to 4600ms of the time.

Additional info:
Please look at:

systemd 189-3
linux 3.5.3-1


MODULES="ext4 i915 ahci sd_mod"
HOOKS="base udev lvm2 autodetect timestamp keymap consolefont"

I tried remove /etc/vconsole.conf, changing font, keymap, adding and removing keymap and consolefont to initramfs, but it doesn't help.
I also installed fresh Arch on my second laptop, but with exactly the same list of packages, and I have the same problem.

Steps to reproduce:
Install Arch, switch to systemd (steps on wiki)
This task depends upon

Closed by  Gaetan Bisson (vesath)
Sunday, 09 September 2012, 16:03 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Thursday, 30 August 2012, 02:59 GMT
This just looks like disk thrash. Really nothing to fix here. I'd honestly be more concerned about the nearly 2s udevadm trigger call, but I'm sure its just another symptom of the same problem.

Enable readahead services, reboot a few times, buy an SSD....

I'd fix your mkinitcpio config, too. lvm shouldn't be before autodetect unless you have some insane bug (which should be fixed, not worked around like that), and I'd advise against using such silly compression. If you care about boot time so much, use gzip and leave COMPRESSION_OPTIONS alone.
Comment by Ypnose (Ypnose) - Sunday, 02 September 2012, 17:09 GMT
Maybe it's not a bug but compared to my Fedora 17 + XFCE with Core2Duo T6400 2GHz + 4Go, "systemd-vconsole-setup.service" takes 1904 ms.
Today, I did a fresh install (pure systemd + sysvcompat) with Phenom II X4 955 + 8Go, "systemd-vconsole-setup.service" takes 3889 ms.

As you can see, there is a gap. I'm running linux 3.5.3 + systemd 189-4
I don't get why this service seems to be long.
   OUT.out (0.7 KiB)
Comment by Dave Reisner (falconindy) - Sunday, 02 September 2012, 17:18 GMT
And? Run /usr/lib/systemd/systemd-vconsole-setup after you boot and tell me how long it takes.
Comment by Ypnose (Ypnose) - Sunday, 02 September 2012, 17:42 GMT
It takes 30ms.
   OUT.out (0.6 KiB)
Comment by Dave Reisner (falconindy) - Sunday, 02 September 2012, 17:48 GMT
Exactly my point -- this is disk thrash on startup.
Comment by Ypnose (Ypnose) - Sunday, 02 September 2012, 17:51 GMT
Ok. Thanks for the help.
My apologies.
Good work anyway.

Take care.