Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31323 - [xorg-server] xfwm4 decoration is incomplete

Attached to Project: Arch Linux
Opened by Mihai Coman (z0id) - Tuesday, 28 August 2012, 18:18 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 28 December 2012, 10:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:

The title bar part of the decoration is missing [1]. It is not just transparent, as I can click through it.
The issue is present with some themes, e.g. present with elementary and not with zukitwo, sammy, or the default themes.
Additional info:

* package version

xorg-server 1.12.4-1
xfwm4 4.10.0-2

* screenshot

[1] http://s14.directupload.net/images/120828/tepaa9zs.png
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 28 December 2012, 10:29 GMT
Reason for closing:  Upstream
Comment by Jonathan Dlouhy (oboedad55) - Tuesday, 28 August 2012, 18:43 GMT
Same problem with Greybird theme from AUR.
Comment by philomath (archadmirer) - Tuesday, 28 August 2012, 21:13 GMT Comment by Scott Olson (tsion) - Tuesday, 28 August 2012, 21:22 GMT
I don't think so. That sounds like xfwm4 died and thus all the window borders it renders were gone. In this bug, the window borders are only partially missing (and just for certain themes) and xfwm4 is not dead. (xfwm4 --replace doesn't help)
Comment by Maksim Yakovlev (lampslave) - Tuesday, 28 August 2012, 23:11 GMT
Rollback of Xorg can fix this.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 29 August 2012, 18:17 GMT
The issue appears to be caused by the latest xorg-server release.

There is an upstream bug report opened by a fellow Archer with more details:

https://bugs.freedesktop.org/show_bug.cgi?id=54168
Comment by Jonathan Dlouhy (oboedad55) - Thursday, 30 August 2012, 02:38 GMT
Problem is fixed for me after today's updates. Greybird theme is now working.
Comment by Evangelos Foutras (foutrelis) - Thursday, 30 August 2012, 02:57 GMT
That would be because Greybird's author has added a workaround [1].

The underlying bug is still there.

[1] https://github.com/shimmerproject/Greybird/commit/315b768cd62fde0d77019f0575e2e620033e9c64
Comment by Lucas Martin-King (irrationalidiom) - Monday, 03 September 2012, 13:05 GMT
I'm using the latest nvidia drivers (304.43-1), xorg-server (1.12.4-1) and xfwm4 (4.10.0-2)

As seen in the attached image, the left border is missing, and the right border is offset by 1px to the right, and the area where the RHS border should be is transparent.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 24 October 2012, 12:08 GMT
Status with xorg-server 1.13.0? (Please test with elementary-gtk-theme.)
Comment by Thomas (radioactiveman) - Sunday, 28 October 2012, 23:02 GMT
Nothing has changed with 1.13.0.
Comment by Andreas Radke (AndyRTR) - Friday, 28 December 2012, 10:29 GMT
I'm CC'ed to the upstream report. Closing this one.

Loading...