Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31311 - [xf86-video-intel] 2.20.5-1 crashes with SNA acceleration

Attached to Project: Arch Linux
Opened by Thomas Bächler (brain0) - Tuesday, 28 August 2012, 08:31 GMT
Last edited by Thomas Bächler (brain0) - Wednesday, 05 September 2012, 08:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

On my first generation intel HD graphics (Arrandale CPU, Ironlake GPU), 2.20.5-1 crashes after a few minutes of usage when SNA acceleration is enabled. I just switched back to UXA to see if the crash still occurs there, which didn't happen yet.
This task depends upon

Closed by  Thomas Bächler (brain0)
Wednesday, 05 September 2012, 08:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.20.6
Comment by mangust (mangust) - Tuesday, 28 August 2012, 09:51 GMT
The same problem. After updating to xf86-video-intel 2.20.5-1 I have random X crash. I use KDE4.9. Here is the log of kdm.log:
---------------------------
Backtrace:
0: /usr/bin/X (xorg_backtrace+0x36) [0x560366]
1: /usr/bin/X (0x400000+0x1640c9) [0x5640c9]
2: /lib/libpthread.so.0 (0x7f8794f2e000+0xf170) [0x7f8794f3d170]
3: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f8791f0d000+0x5ec6e) [0x7f8791f6bc6e]
4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f8791f0d000+0xb8e2a) [0x7f8791fc5e2a]
5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f8791f0d000+0x615fe) [0x7f8791f6e5fe]
6: /usr/bin/X (0x400000+0xf2119) [0x4f2119]
7: /usr/bin/X (0x400000+0xeb084) [0x4eb084]
8: /usr/bin/X (0x400000+0x34531) [0x434531]
9: /usr/bin/X (0x400000+0x23615) [0x423615]
10: /lib/libc.so.6 (__libc_start_main+0xf5) [0x7f8793ddd725]
11: /usr/bin/X (0x400000+0x238ed) [0x4238ed]

Segmentation fault at address 0x7a

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting
---------------------------
Turning of SNA acceleration (switching to UXA) eliminates the problem.


P.S.
Just updated to 3.5.3-1 ..... might solve the problem. I'll report if there're some changes.

BR
Comment by mangust (mangust) - Tuesday, 28 August 2012, 14:14 GMT
No, no difference with linux 3.5.3-1. Using xf86-video-intel 2.20.5-1 X crashes randomly.
Log output:
---------------------------
Backtrace:
0: /usr/bin/X (xorg_backtrace+0x36) [0x560366]
1: /usr/bin/X (0x400000+0x1640c9) [0x5640c9]
2: /lib/libpthread.so.0 (0x7f0a48637000+0xf170) [0x7f0a48646170]
3: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f0a45616000+0x5ec6e) [0x7f0a45674c6e]
4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f0a45616000+0xb8e2a) [0x7f0a456cee2a]
5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f0a45616000+0x615fe) [0x7f0a456775fe]
6: /usr/bin/X (0x400000+0xf2119) [0x4f2119]
7: /usr/bin/X (0x400000+0xeb084) [0x4eb084]
8: /usr/bin/X (0x400000+0x34531) [0x434531]
9: /usr/bin/X (0x400000+0x23615) [0x423615]
10: /lib/libc.so.6 (__libc_start_main+0xf5) [0x7f0a474e6725]
11: /usr/bin/X (0x400000+0x238ed) [0x4238ed]

Segmentation fault at address 0x7a

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1). Closing log file.
---------------------------

System info:
-- DE
KDE4.9 x86_64
Desktop Effects:
Compositing type = OpenGL
Qt graphics system = Native
-- Hardware
Lenovo ThinkPad Edge E320
Intel(R) Core(TM) i3-2330M CPU @ 2.20GHz
Comment by Lukas Redynk (erdk) - Tuesday, 28 August 2012, 14:15 GMT
I've got the same issue, my specs:
Core-i7 2630QM, SNA, with enabled RC6 'i915.i915_enable_rc6=1', backtrace same like in 1-st post.

I've observed, that with intel-2.20.5 firefox crashes 100% times on this page: http://www.archlinux.org/visualize/
so it could be used for testing.
Comment by mangust (mangust) - Tuesday, 28 August 2012, 14:38 GMT
I have no crashes on page http://www.archlinux.org/visualize/ with intel-2.20.5 and firefox 14.
@erdk: Do you have RC6 mode manually turned on? I'm not sure, but the RC6 mode is turned on by default.
Comment by Lukas Redynk (erdk) - Tuesday, 28 August 2012, 17:25 GMT
@mangust: yes, but the 'shallowest' one, I've got problems with deep and deepest. In modinfo there's info that default is '-1' - per chip default. About crashes: have you enabled 'Preferences -> Advanced -> Use hardware acceleration when available' in firefox?
Comment by mangust (mangust) - Tuesday, 28 August 2012, 17:56 GMT
@erdk: yes, I've enabled 'Use hardware acceleration when available'
I'm turning off SNA as temporary solution.
Comment by Lukas Redynk (erdk) - Tuesday, 28 August 2012, 18:15 GMT
@mangust: returning to 2.20.4 also work - no crashes whit SNA.
Comment by Gustaf Hallberg (ghallberg) - Wednesday, 29 August 2012, 07:40 GMT
Confirming that reverting to 2.20.4 works.
Comment by Jan de Groot (JGC) - Wednesday, 29 August 2012, 08:16 GMT
I can't reproduce this on my sandybridge hardware, so I can't test. It's quite clear that SNA on 2.20.5 is broken, so some commit between 2.20.4 and 2.20.5 breaks SNA for your hardware. It would be nice if someone can test if it's already fixed in git master, and if not, it would be nice if someone could use git bisect to find the bad commit and inform upstream about the problem. Then they can fix this and release 2.20.6.
Comment by stewu (stewu) - Friday, 31 August 2012, 18:58 GMT
I can reproduce the crashes with chromium on my ivybridge hardware (intel hd4000):
1. open chromium
2. click on a download link (save-as-dialog appears)
3. click on save
*CHRASH*

i915.i915_enable_rc6=1 was set via kernel command line and rc6 is enabled in UEFI.
I didn't test without these settings.
Reverted to 2.20.4 -> no problems.
Comment by Florian Merz (fiji-flo) - Saturday, 01 September 2012, 12:56 GMT
I had the same seg fault on my ivy bridge laptop (hd 4000) with sna enabled.
Downgrading to 2.20.4 workes.

Today I teststed the current git version of xf86-video-intel and it seems like this bug has been fixed.
I couldn't reproduce the crash anymore.
Comment by Felix Werner (fwerner) - Wednesday, 05 September 2012, 07:57 GMT
Upgrading to 2.20.6-1 did not fix the problem for me. It actually made it worse, since X now crashes also when using UXA. I've downgraded to 2.20.5-1 and use UXA for now.
Comment by Andreas Radke (AndyRTR) - Wednesday, 05 September 2012, 07:58 GMT
Please report this upstream. This issue seems to be not yet fixed.
Comment by Thomas Bächler (brain0) - Wednesday, 05 September 2012, 08:02 GMT
Actually, the issue where intel crashes with SNA (and not with UXA) is fixed.

Please open a NEW bug report for a NEW issue, instead of confusing old and new bugs.

Loading...