Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31302 - pacman should handle key signature updates better

Attached to Project: Arch Linux
Opened by Johannes Jordan (FoPref) - Monday, 27 August 2012, 09:43 GMT
Last edited by Dave Reisner (falconindy) - Monday, 27 August 2012, 10:03 GMT
Task Type Feature Request
Category System
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When updating, a developer's key was unsigned. I checked the website to find that the developer's key should be signed by several master keys. I had forgotten about the pacman-keys command and used gpg --homedir etc. to refresh the keys.

IMHO, pacman should either call pacman-key --refresh-keys itself or point the user to it.

Other users also have problems with keys and ask in the forums about it. The error message given is not easily understandable for people without gpg knowledge.
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 27 August 2012, 10:03 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#28014 
Comment by Johannes Jordan (FoPref) - Monday, 27 August 2012, 09:49 GMT
Could pacman always update archlinux-keyring first, as it does with the "pacman" package?
Comment by Dave Reisner (falconindy) - Monday, 27 August 2012, 10:03 GMT
SyncFirst no longer exists. This is really just a dupe of 28014.

Loading...