Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#31270 - [linux] 3.4.x -3.5.x Enable CONFIG_X86_X32 for Linux kernel

Attached to Project: Arch Linux
Opened by Nikolay Amiantov (abbradar) - Friday, 24 August 2012, 16:29 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 16 September 2012, 16:55 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Very Low
Priority Low
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No


Enable x32 ABI support in kernel so those who want to try it doesn't need to compile their own kernel. I understand that x32 is not supported by Arch Linux, but this should not harm in any way, and allow running binaries for this ABI.

Additional info:
* package version(s)
* config and/or log files etc.
core/linux 3.4.9-1 (base)

Steps to reproduce:
1. Try to run x32 binary.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 16 September 2012, 16:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.5.4-1
Comment by Fantix King (fantix) - Saturday, 08 September 2012, 06:51 GMT
Any update on this please? I would really like to have it in official kernel, so that I don't have to maintain AURs like linux-x32, virtualbox-modules-x32. Looking forward to see the decisions. Thank you very much.