Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31262 - [chromium] no longer provides chromium-browser?

Attached to Project: Arch Linux
Opened by arielp (ajp) - Thursday, 23 August 2012, 18:58 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 24 August 2012, 08:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
As of version 21.0.1180.81-2 the package has dropped the provides and conflicts entries for chromium-browser. Was this on purpose, and I just need to wait for the things that require chromium-browser to update?

This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 24 August 2012, 08:35 GMT
Reason for closing:  Not a bug
Comment by xduugu (xduugu) - Thursday, 23 August 2012, 20:54 GMT
As far as I know, Arch never had a chromium-browser package, but the name came from debian. Thus, in my opinion, all chromium packages should provide "chromium" since this is the official package name.
Comment by Evangelos Foutras (foutrelis) - Friday, 24 August 2012, 00:32 GMT
It was intentional, but I forgot to mention it in the commit message. I'll admit I didn't give it much thought since nothing in the repos made use of the alternate name.

Like xduugu said, AUR packages that provide/depend on chromium-browser should switch to the canonical name.

Loading...