Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31231 - [cronie] [systemd] /etc/conf.d/crond is ignored

Attached to Project: Arch Linux
Opened by fandrieu (fandrieu) - Tuesday, 21 August 2012, 22:14 GMT
Last edited by Dave Reisner (falconindy) - Tuesday, 21 August 2012, 22:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When using systemd, the $CRONDARGS variable in /etc/conf.d/crond has no effect.

Additional info:
* cronie 1.4.8-3

Steps to reproduce:

$ ps ax | grep crond
/usr/sbin/crond -n
$ echo CRONDARGS="-s m off" > /etc/conf.d/crond
$ systemctl restart cronie.service
$ ps ax | grep crond
/usr/sbin/crond -n

Simple fix in /usr/lib/systemd/system/cronie.service (attached):
<...>
EnvironmentFile=/etc/conf.d/crond
ExecStart=/usr/sbin/crond -n $CRONDARGS

This task depends upon

Closed by  Dave Reisner (falconindy)
Tuesday, 21 August 2012, 22:40 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Working as intended.
Comment by Dave Reisner (falconindy) - Tuesday, 21 August 2012, 22:40 GMT
Working as intended (and as advised by upstream). If you don't want mail, you can override the unit in /etc/systemd/system.

Loading...