Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31153 - [boost] boost-python is broken

Attached to Project: Arch Linux
Opened by جاك الفضة (jacksilver) - Thursday, 16 August 2012, 13:44 GMT
Last edited by Stéphane Gaudreault (stephane) - Thursday, 10 January 2013, 12:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Stéphane Gaudreault (stephane)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I want to use libboost_python.so, but my simple test code fails to build.

Additional info:
* package version(s)

boost 1.50.0-2
gcc 4.7.1-5
glibc 2.16.0-2
python 3.2.3-3

Steps to reproduce:

My simple test code is following.

cat > test_boost.c <<EOF
int main ()
{
return 0;
}
EOF

gcc -o test_boost -L/usr/lib -lboost_python -lpython3 test_boost.c

Error message in attch.
   gcc.log (1.2 KiB)
This task depends upon

Closed by  Stéphane Gaudreault (stephane)
Thursday, 10 January 2013, 12:47 GMT
Reason for closing:  Not a bug
Comment by جاك الفضة (jacksilver) - Thursday, 16 August 2012, 14:19 GMT
Worked if boost rebuild with python3
Comment by جاك الفضة (jacksilver) - Thursday, 20 December 2012, 22:29 GMT
I wanna like to help. Is there anything that prevent the fix of this ?
Comment by Stéphane Gaudreault (stephane) - Wednesday, 09 January 2013, 01:19 GMT
What about linking with this command ?

gcc -o test_boost -L/usr/lib -lboost_python3 -lpython3 test_boost.c

This one works for me.

Loading...