Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31147 - [wpa_supplicant] Typo in systemd files

Attached to Project: Arch Linux
Opened by Håkon Vågsether (hauk142) - Wednesday, 15 August 2012, 22:47 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 16 August 2012, 23:12 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
In all of wpa_supplicant's .service files in /usr/lib/systemd/system/, there is a typo.
In the Requires and After field, "%I" is written with a lowercase "I", calling sys-subsystem-net-devices-%i.device (instead of sys-subsystem-net-devices-%I.device),
which won't work because no interface is then specified, and it times out. wpa_supplicant can therefore do nothing, and ends up dead in systemctl.

Additional info:
wpa_supplicant 1.0-1 (base)
systemd 188-2
systemd-arch-units 20120704-2

Steps to reproduce:
- Install systemd
- Use systemctl to enable wpa_supplicant on an interface (also enable dhcpcd if you haven't)
- reboot/start the services
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 16 August 2012, 23:12 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#30235 
Comment by Dave Reisner (falconindy) - Thursday, 16 August 2012, 22:16 GMT
Uh, what? The '%i' tokens are correct, but there's a bug in systemd that prevents these units from working properly. I don't know what you're talking about with reference to any %l tokens.
Comment by Håkon Vågsether (hauk142) - Thursday, 16 August 2012, 23:05 GMT
I am sorry if I am being unclear here. What I meant is tAnd,hat several of the other files using the "%i" token have it in uppercase, like "%I". And I fixed my problem with wpa_suppicant by changing "%i" to "%I". But, if you say the problem is systemd not letting the units work properly, I believe you. :)

Loading...