Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31115 - [NetworkManager] 0.9.6.0-1 brings back bug #30305

Attached to Project: Arch Linux
Opened by Ryan (Kirby) - Sunday, 12 August 2012, 21:19 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 19 September 2012, 08:16 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After enable the testing repositories and updating networkmanager to 0.9.6.0-1, SIGTERM hangs for a few seconds, then displays FAILS and moves on. Exact same problem as this

https://bugs.archlinux.org/task/30305

I never had such a problem with networkmanager 0.9.4.0-6, either

Additional info:
networkmanager 0.9.6.0-1

can remedy the problem by removing networkmanager from rc.conf, but of course, I lose the functionality.

Steps to reproduce:
Shutdown/Restart from KDE start menu
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 19 September 2012, 08:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.9.6.0-2
Comment by Ionut Biru (wonder) - Sunday, 12 August 2012, 21:33 GMT
please provide logs.
Comment by Ryan (Kirby) - Sunday, 12 August 2012, 22:36 GMT
Hello,

I don't seem to notice any noteworthy errors at startup or shutdown. I uploaded the log of NetworkManager starting up, just in case I missed something.

I also noticed that networkmanager can't be SIGTERMed when daemonized, only SIGKILLed. If I don't run it as a daemon, SIGTERM takes care of it fine at shutdown
Comment by Jan Alexander Steffens (heftig) - Tuesday, 14 August 2012, 15:20 GMT
Please try installing dhclient and adding dhcp=dhclient to the [main] section in /etc/NetworkManager/NetworkManager.conf.
Comment by Ryan (Kirby) - Tuesday, 14 August 2012, 18:02 GMT
Hello,

doesn't look like this changed anything, except for some extra dhclient lines
Comment by Jan Alexander Steffens (heftig) - Wednesday, 15 August 2012, 03:10 GMT
Are you using VPNs?
Comment by Ryan (Kirby) - Wednesday, 15 August 2012, 18:02 GMT
Hello,

I have the pptp and openvpn plugins installed, but no VPN set up. I had the problem before installing those plugins
Comment by Serge Roussak (beaux_monde) - Monday, 20 August 2012, 11:32 GMT
I can confirm this bug.
In addition I can provide this information: when NetworkManager started as daemon it does not respond to the SIGTERM signal (therefore it does not shut down while rebooting/shutting down the system), but when I launched it with --no-daemon command line parameter it exited on SIGTERM.

I'm sorry for my English. :-)
Comment by Jan Alexander Steffens (heftig) - Monday, 20 August 2012, 18:26 GMT
Please file this upstream to https://bugzilla.gnome.org/ .
Comment by Martín Cigorraga (msx) - Wednesday, 19 September 2012, 07:57 GMT
Does anybody have already reported this bug upstream? If so I would like to know the name of that report to add mine's because I can't find any networkmanager report related with this issue, thanks!

Loading...