Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31089 - Failed to issue method call: Did not receive a reply. Possible causes include: the remote applicatio

Attached to Project: Arch Linux
Opened by Anarconda (Anarconda) - Friday, 10 August 2012, 08:36 GMT
Last edited by Dave Reisner (falconindy) - Friday, 10 August 2012, 23:24 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version 4.0.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

[root@Gaia amarcord]# pacman -Syu
:: Sincronizando las bases de datos de paquetes...
kde-unstable está actualizado
testing 30,7 KiB 94,1K/s 00:00 [######################] 100%
core está actualizado
extra 1412,3 KiB 542K/s 00:03 [######################] 100%
community 1755,3 KiB 605K/s 00:03 [######################] 100%
:: Iniciando actualización completa del sistema...
resolviendo dependencias...
verificando conflictos...

Objetivos (9): device-mapper-2.02.97-1 libguess-1.1-2 libmowgli-2.0.0-1
libsystemd-188-1 libxml2-2.8.0-1 lvm2-2.02.97-1 rtkit-0.11-1
systemd-188-1 systemd-tools-188-1

Tamaño de descarga: 3,53 MiB
Tamaño instalado: 23,99 MiB
Tamaño a actualizar: 0,38 MiB

¿Continuar con la instalación? [S/n] s
:: Descargando paquetes desde testing...
libsystemd-188-1-x86_64 56,6 KiB 76,6K/s 00:01 [######################] 100%
systemd-tools-188-1... 414,8 KiB 578K/s 00:01 [######################] 100%
device-mapper-2.02.... 154,3 KiB 1524K/s 00:00 [######################] 100%
libxml2-2.8.0-1-x86_64 1475,6 KiB 852K/s 00:02 [######################] 100%
lvm2-2.02.97-1-x86_64 623,6 KiB 939K/s 00:01 [######################] 100%
systemd-188-1-x86_64 790,2 KiB 855K/s 00:01 [######################] 100%
:: Descargando paquetes desde extra...
libmowgli-2.0.0-1-x... 66,4 KiB 791K/s 00:00 [######################] 100%
libguess-1.1-2-x86_64 7,2 KiB 3,77M/s 00:00 [######################] 100%
rtkit-0.11-1-x86_64 22,7 KiB 429K/s 00:00 [######################] 100%
(9/9) verificando la integridad de los paquetes [######################] 100%
(9/9) cargando los archivos del paquete... [######################] 100%
(9/9) verificando conflictos entre archivos [######################] 100%
(9/9) verificando el espacio disponible en disco [######################] 100%
(1/9) actualizando libsystemd [######################] 100%
(2/9) actualizando systemd-tools [######################] 100%
(3/9) actualizando device-mapper [######################] 100%
(4/9) actualizando libmowgli [######################] 100%
(5/9) actualizando libguess [######################] 100%
(6/9) actualizando libxml2 [######################] 100%
(7/9) actualizando lvm2 [######################] 100%
(8/9) actualizando rtkit [######################] 100%
(9/9) actualizando systemd [######################] 100%
Failed to issue method call: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.



Steps to Reproduce:

No idea, next #pacman -Syu was as usual (obviously without anything to update).

TIA
This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 10 August 2012, 23:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  testing/systemd-188-2
Comment by Jelle van der Waa (jelly) - Friday, 10 August 2012, 08:38 GMT
http://lists.freedesktop.org/archives/systemd-devel/2010-October/000616.html

This is probably a none bug, but the next time please use an attachment for large output and use LANG=C command.
Comment by Anarconda (Anarconda) - Friday, 10 August 2012, 08:41 GMT
Ok. I'll do it that way.
Comment by Dave Reisner (falconindy) - Friday, 10 August 2012, 10:02 GMT
No, its a real bug. Hrmm, thought there was an ML post about it but maybe it was just mentioned in IRC. It's because of this merge:

http://lists.freedesktop.org/archives/systemd-devel/2012-August/006170.html
Comment by Dave Reisner (falconindy) - Friday, 10 August 2012, 14:35 GMT
not a bug in pacman, though... wtf...

This might just be a "display" issue. Doesn't seem there's any negative effects from this.
Comment by Jelle van der Waa (jelly) - Friday, 10 August 2012, 14:39 GMT
Dave, isn't the post.install causing this?
Comment by Dave Reisner (falconindy) - Friday, 10 August 2012, 14:44 GMT
Sure it is. But the message is only displayed because the error handling is done unconditionally by bus_method_call_with_reply() now. systemctl used to only conditionally print the "error" from the (expected) bus disconnect on reexec.
Comment by Dave Reisner (falconindy) - Friday, 10 August 2012, 17:12 GMT

Loading...