Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31087 - [nvidia-utils] Gnome window screen capture is broken

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Friday, 10 August 2012, 07:11 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Saturday, 17 November 2012, 03:46 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Hello.

Find a weird bug using gnome screenshot. If you want to have a single window screenshot using either alt+PrintScreen or GUI interface, you'll get a corrupted file. I'm also using nvidia driver.

Got this in my .xsession-error log file :

** (gnome-screenshot:27677): WARNING **: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11. Error: Le fichier image « /home/fred/.cache/gnome-screenshot/scr--1328043383.png » ne contient pas de données

(gnome-screenshot:27677): Gdk-CRITICAL **: gdk_pixbuf_get_from_surface: assertion `width > 0 && height > 0' failed

(gnome-screenshot:27677): Gtk-CRITICAL **: gtk_window_resize: assertion `width > 0' failed

** (gnome-screenshot:27677): CRITICAL **: Unable to capture a screenshot of any window

Of course, it worked with previous xorg-server version.

I know testing can be broken, so I'm reporting this bug which looks like a testing package problem.

Additional info:
xorg-server 1.12.3.901-1
gnome-screenshot 3.4.1-1
nvidia 304.32-2

Steps to reproduce: Have a fully up-to-date archlinux with testing and gnome.
Press alt+printscreen.
See the result.
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Saturday, 17 November 2012, 03:46 GMT
Reason for closing:  Upstream
Comment by Frederic Bezies (fredbezies) - Friday, 10 August 2012, 08:36 GMT
Some more infos on this bug, found after I filed this bug.

1) Downgrading to previous version : not working.
2) Replacing nvidia by nouveau : working.

So it could be a nvidia driver bug.
Comment by Ionut Biru (wonder) - Friday, 10 August 2012, 10:10 GMT Comment by Frederic Bezies (fredbezies) - Friday, 10 August 2012, 10:26 GMT Comment by Frederic Bezies (fredbezies) - Tuesday, 28 August 2012, 19:41 GMT
Still busted with nvidia 304.37
Comment by Frederic Bezies (fredbezies) - Wednesday, 03 October 2012, 05:27 GMT
Needless to say nvidia 304.51 is still broken :(
Comment by Frederic Bezies (fredbezies) - Saturday, 20 October 2012, 11:05 GMT
Apparently, this bug is fixed in incoming drivers.

http://www.nvnews.net/vbulletin/showpost.php?s=e6b973d1a0876b49e41c9672dc65508f&p=2578810&postcount=9

"It is working for me on Fedora 18 with Xorg 1.13.0 and nvidia 310.14."
Comment by Greg (dolby) - Tuesday, 06 November 2012, 21:04 GMT
Still a problem with 304.64?
Comment by Frederic Bezies (fredbezies) - Tuesday, 06 November 2012, 21:07 GMT
Do not test nVidia 304.64, but I don't think it will fix this bug.

Changelog of 304.64 version :

Added support for the following GPUs:
VGX K1
VGX K2
Added a missing 32-bit compatibility library for libnvidia-opencl.so to the 64-bit Linux installer package.
Fixed a regression in backlight control functionality on some notebook configurations.
Fixed a performance issue with recent Linux kernels when allocating and freeing system memory.
Fixed a bug that sometimes prevented the display device / X screen selection menu from being displayed in nvidia-settings.
Fixed a bug that prevented X driver gamma manipulation from working after a VT-switch on some configurations.
Added the option "--output-file" to nvidia-bug-report.sh to allow specifying a custom filename for the log file.
Fixed a hang when using OpenGL programs with some SLI Mosaic configurations on pre-Fermi GPUs.
Added sections to the "Supported NVIDIA GPU Products" list for NVS, Tesla, and VGX products.

Nothing related to broken screenshot.

Loading...