Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#31072 - makepkg gzips symbolic links and already gzipped files

Attached to Project: Pacman
Opened by Ramana Kumar (xrchz) - Thursday, 09 August 2012, 11:59 GMT
Last edited by Allan McRae (Allan) - Thursday, 13 December 2012, 15:53 GMT
Task Type Feature Request
Category makepkg
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.0.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Packages may use symbolic links for man pages (e.g. https://aur.archlinux.org/packages.php?ID=55089).

With the zipman option, the links get gzipped and may appear gzipped twice, leading to the man invocations failing (bogus filename).
For example, the link becomes:
pkg/usr/share/man/man1/dmtcp_restart.1.gz.gz -> dmtcp.1.gz

Without zipman, the non-link pages don't get gzipped, which is undesirable.
For example, the link becomes:
pkg/usr/share/man/man1/dmtcp_restart.1.gz -> dmtcp.1

I request that makepkg don't zip links, and/or don't zip anything twice.
I would also be interested in other solutions for this kind of package: is it an upstream problem?
This task depends upon

Closed by  Allan McRae (Allan)
Thursday, 13 December 2012, 15:53 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Thursday, 09 August 2012, 12:37 GMT
Ah... screwed up package. Building without zipman gives:

-rw-r--r-- 1 allan allan 9373 Aug 9 22:35 dmtcp.1
lrwxrwxrwx 1 allan allan 7 Aug 9 22:35 dmtcp_checkpoint.1.gz -> dmtcp.1
lrwxrwxrwx 1 allan allan 7 Aug 9 22:35 dmtcp_command.1.gz -> dmtcp.1
lrwxrwxrwx 1 allan allan 7 Aug 9 22:35 dmtcp_coordinator.1.gz -> dmtcp.1
lrwxrwxrwx 1 allan allan 7 Aug 9 22:35 dmtcp_inspector.1.gz -> dmtcp.1
lrwxrwxrwx 1 allan allan 7 Aug 9 22:35 dmtcp_nocheckpoint.1.gz -> dmtcp.1
lrwxrwxrwx 1 allan allan 7 Aug 9 22:35 dmtcp_restart.1.gz -> dmtcp.1
lrwxrwxrwx 1 allan allan 7 Aug 9 22:35 mtcp.1.gz -> dmtcp.1
lrwxrwxrwx 1 allan allan 7 Aug 9 22:35 mtcp_restart.1.gz -> dmtcp.1

> file pkg/usr/local/share/man/man1/dmtcp.1
pkg/usr/local/share/man/man1/dmtcp.1: troff or preprocessor input, ASCII text

So the install script for that package is naming the symlinks as though the file is compressed.

I say this is not a makepkg bug.
Comment by Ramana Kumar (xrchz) - Thursday, 09 August 2012, 13:03 GMT
OK I agree that it is the package, and not makepkg, that is broken in this case.
The feature request to not zip links and not zip twice still stands, but is maybe less important since I don't have a good example.
Comment by Allan McRae (Allan) - Thursday, 09 August 2012, 20:55 GMT
makepkg does not zip twice... if the real file was compressed, it would not compress it.

Loading...