Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31043 - [midori] crashes on loading page

Attached to Project: Community Packages
Opened by Benjamin van der Burgh (Gringo) - Tuesday, 07 August 2012, 11:25 GMT
Last edited by Alexander F. Rødseth (xyproto) - Monday, 20 August 2012, 00:36 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ionut Biru (wonder)
Alexander F. Rødseth (xyproto)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm on an up-to-date Arch Linux x86 installation and I noticed Midori crashes on loading www.saeco.com . I used the PKGBUILD from here http://www.archlinux.org/packages/community/i686/midori/
and added '-d all' to the configure command to compile with debug symbols.

When I click on the URL I can see the browser connecting to the webserver and loading the page title, but after that it crashes. All messages and the backtrace are at the bottom of the report.

Here is some information on the packages that are installed on my system:

Environment information

Desktop environment: XFCE 4.10
X-server: 1.12.3
Linux kernel: 3.4.7

about:version

Command line ~/midori/src/midori-0.4.6/_build/default/midori/midori
Midori 0.4.6 (debug) (de.twotoasts.midori_14d408523cd11bbc93f80a242cf0d1a3__0)
GTK+ 2.24.11 (2.24.11)
Glib 2.32.4 (2.32.4)
WebKitGTK+ 1.8.2 (1.8.2)
libsoup 2.38.1
cairo 1.12.2 (1.12.2)
granite No
libnotify 0.7.5
single instance libunique 1.1.6

Message log and backtrace

[user@host midori-0.4.6]$ gdb _build/default/midori/midori
GNU gdb (GDB) 7.4.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/user/midori/src/midori-0.4.6/_build/default/midori/midori...done.
(gdb) run
Starting program: /home/user/midori/src/midori-0.4.6/_build/default/midori/midori
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
Traceback (most recent call last):
File "/usr/share/gdb/auto-load/usr/lib/libgobject-2.0.so.0.3200.4-gdb.py", line 9, in <module>
from gobject import register
File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
import gdb.backtrace
ImportError: No module named backtrace
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
[New Thread 0xb1aa5b40 (LWP 22459)]
[New Thread 0xb10ffb40 (LWP 22460)]
[New Thread 0xb07feb40 (LWP 22461)]
[New Thread 0xafdffb40 (LWP 22462)]
WARNING: gnome-keyring:: couldn't connect to: /home/user/.cache/keyring-CO6WVa/pkcs11: No such file or directory
[Thread 0xb07feb40 (LWP 22461) exited]
[New Thread 0xb07feb40 (LWP 22463)]
[New Thread 0xac3cfb40 (LWP 22466)]
[New Thread 0xab51fb40 (LWP 22467)]
[New Thread 0xaacbab40 (LWP 22468)]
[New Thread 0xaa111b40 (LWP 22469)]
[New Thread 0xa8958b40 (LWP 22470)]
[Thread 0xab51fb40 (LWP 22467) exited]
[Thread 0xaacbab40 (LWP 22468) exited]
[Thread 0xa8958b40 (LWP 22470) exited]
[New Thread 0xa8958b40 (LWP 22639)]
[New Thread 0xaacbab40 (LWP 22640)]
[New Thread 0xab51fb40 (LWP 22641)]

Program received signal SIGSEGV, Segmentation fault.
0xb6729577 in ?? () from /lib/libwebkitgtk-1.0.so.0
(gdb) bt
#0 0xb6729577 in ?? () from /lib/libwebkitgtk-1.0.so.0
#1 0xb67263cd in ?? () from /lib/libwebkitgtk-1.0.so.0
#2 0xb7f7b37f in g_cclosure_marshal_VOID__VOID () from /lib/libgobject-2.0.so.0
#3 0xb7f79616 in g_closure_invoke () from /lib/libgobject-2.0.so.0
#4 0xb7f8b105 in ?? () from /lib/libgobject-2.0.so.0
#5 0xb7f932f6 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#6 0xb7f93473 in g_signal_emit () from /lib/libgobject-2.0.so.0
#7 0xb761239d in soup_message_got_headers () from /lib/libsoup-2.4.so.1
#8 0xb7618408 in ?? () from /lib/libsoup-2.4.so.1
#9 0xb7f7b3e7 in g_cclosure_marshal_VOID__VOIDv () from /lib/libgobject-2.0.so.0
#10 0xb7f798c1 in ?? () from /lib/libgobject-2.0.so.0
#11 0xb7f92a19 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#12 0xb7f93473 in g_signal_emit () from /lib/libgobject-2.0.so.0
#13 0xb76280fc in ?? () from /lib/libsoup-2.4.so.1
#14 0xb7825039 in ?? () from /lib/libgio-2.0.so.0
#15 0xb7eb9733 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#16 0xb7eb9ad0 in ?? () from /lib/libglib-2.0.so.0
#17 0xb7eb9f2b in g_main_loop_run () from /lib/libglib-2.0.so.0
#18 0xb7afcdd0 in gtk_main () from /lib/libgtk-x11-2.0.so.0
#19 0x08067689 in main (argc=1, argv=0xbffff364) at ../midori/main.c:2574
(gdb) quit
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Monday, 20 August 2012, 00:36 GMT
Reason for closing:  Fixed
Comment by Bartłomiej Piotrowski (Barthalion) - Saturday, 11 August 2012, 10:07 GMT
Thanks for providing the log, but unfortunately it doesn't say anything.
If it's not a problem, could you report it to upstream?
Comment by Bartłomiej Piotrowski (Barthalion) - Saturday, 11 August 2012, 10:08 GMT
Btw., bug occurs on x86_64 too.
Comment by Benjamin van der Burgh (Gringo) - Saturday, 11 August 2012, 10:13 GMT
I was unsure if I had to report the bug to the Arch Linux or Midori development team, so I did both.
The upstream report from a few days ago is here: https://bugs.launchpad.net/midori/+bug/1032965

It seems it's not really a priority though, as the report hasn't been touched. It's not that the bug really bothers me, but Midori just crashes sometime at random moments. It's too bad, because I like the browser, but I'm pretty much forced to use something else if I want to be safe from crashes :( This is one of the crashes that I could reproduce.

Thanks for looking into it!
Comment by Bartłomiej Piotrowski (Barthalion) - Saturday, 11 August 2012, 11:17 GMT
It's somehow related to webkit available in our repositories -- Luakit throws segfault, while Firefox, Opera and Chromium work.
Comment by Alexander F. Rødseth (xyproto) - Tuesday, 14 August 2012, 11:08 GMT
Added Ioni, as he might have some insights about webkit.
Comment by Alexander F. Rødseth (xyproto) - Monday, 20 August 2012, 00:36 GMT
I see the midori bug report has a new comment from 2012-08-04:
"no longer affects: midori (Arch Linux)"

Assuming the issue is fixed.

Loading...