Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#31030 - Upgrade Problem With /lib

Attached to Project: Release Engineering
Opened by Carl Carstenson (carstenson) - Monday, 06 August 2012, 13:11 GMT
Last edited by Allan McRae (Allan) - Saturday, 25 August 2012, 10:21 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version testbuild (specify!)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm sorry but I don't have a lot of details for this. It could possibly be something that I did wrong, but it took me six hours to resolve this problem.

I did a full pacman -Syu upgrade to 2012.08.04. It ended up breaking all commands in bash. A forced poweroff/boot then would panic. After booting from a dual iso, I finally discovered that /lib was a symlink to /usr/lib on the iso. It was a shell directory on my hard drive. I was able to rename and create the symlink, which allowed me to then reinstall the linux packages from iso.

Again, I don't know what brought this on and if it is something that needs to be fixed or just a bonehead thing that I did at some point. Thanks.
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 25 August 2012, 10:21 GMT
Reason for closing:  None
Comment by Allan McRae (Allan) - Monday, 06 August 2012, 13:23 GMT
Did you use "--force" with the glibc upgrade?

Loading...