Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31009 - cupsd doesnt start / avahi_client_get_hostname

Attached to Project: Arch Linux
Opened by Thomas Trepl (ernibert) - Saturday, 04 August 2012, 18:59 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 05 August 2012, 11:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Today (4. Aug.12) I did a "pacman -Syu" and after this, cupsd doesnt start anymore. It seems to have some trouble with avahi. See below.


Additional info:
* package version(s)
cups 1.6.1-1

* config and/or log files etc.
[root@io ~]# cupsd -f
Unknown directive BrowseOrder on line 8.
Unknown directive BrowseAllow on line 9.
Unknown directive BrowseRemoteProtocols on line 10.
Unknown directive BrowseAddress on line 11.
Unknown browse protocol "CUPS" ignored.
Unknown directive DefaultAuthType on line 13.
cupsd: client.c:757: avahi_client_get_host_name: Assertion `client' failed.
Abgebrochen
[root@io ~]#

Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 05 August 2012, 11:05 GMT
Reason for closing:  None
Additional comments about closing:  default config is clean about Browsing directives now since 1.6.1-2
Comment by Tom Gundersen (tomegun) - Saturday, 04 August 2012, 19:31 GMT
Can you reproduce with a "clean" cupsd.conf (i.e. either the standard one, or at least one that does not produce any warnings)?
Comment by Andreas Radke (AndyRTR) - Saturday, 04 August 2012, 21:36 GMT
Fix it and read the pacman update msg: check cupsd -t and make sure avahi gets started before your start cupsd.
Comment by Thomas Trepl (ernibert) - Saturday, 04 August 2012, 23:01 GMT
I moved the cupsd.conf.pacnew to cupsd.conf and the result is

[root@io cups]# cupsd -t
Unknown directive BrowseOrder on line 22.
Unknown directive BrowseAllow on line 23.
Unknown directive DefaultAuthType on line 27.
/etc/cups/cupsd.conf is OK
[root@io cups]# rc.d restart cupsd
:: Stopping cupsd daemon [FAIL]
:: Starting cupsd daemon [DONE]

looks promising. I'll keep you updated. Thanks so far.
Comment by Andreas Radke (AndyRTR) - Sunday, 05 August 2012, 08:06 GMT
The default cupsd.conf is not yet updated upstream. Remove those unknown directives or fix the value they have! Then everything will be fine again.

This is definitely a configuration issue and not a bug (expect that the upstream cupsd.conf is outdated - I'm going to report that upstream).
Comment by Andreas Radke (AndyRTR) - Sunday, 05 August 2012, 08:07 GMT
http://www.cups.org/str.php?L4157+Qversion:1.6

It has been reported already. Closing this one.
Comment by Thomas Trepl (ernibert) - Sunday, 05 August 2012, 10:35 GMT
Removing the unknown options and adding the "Allow @LOCAL" options solves my problem.

Thanks to all!


(this "bug" may get closed)

Loading...