Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31007 - [cups] Fails to access the web interface remotely

Attached to Project: Arch Linux
Opened by György Balló (City-busz) - Saturday, 04 August 2012, 17:12 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 05 August 2012, 10:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When I try to access the web interface remotely, I get "Bad Request" error. In previous versions, cups-avahi-5-services.patch enabled some conditionals for avahi, but these changes were not merged into cups, and this causes the problem. Ubuntu solves it by applying a patch[1].

Additional info:
* package version(s)
- cups 1.6.1-1
- avahi 0.6.31-3

Steps to reproduce:
1. Install avahi and nss-mdns, and configure hostname resolution.
2. Start avahi-daemon and then cupsd.
3. Enable remote access on the web interface.
4. Try to visit the web interface as https://<yourhostname>.local:631/

Please apply the patch[1] to fix this bug.

[1] http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/quantal/cups/quantal/view/head:/debian/patches/avahi-not-considered-at-some-dnssd-conditionals.patch
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 05 August 2012, 10:20 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Saturday, 04 August 2012, 21:35 GMT
I can access my server well with https://192.168.1.90:631

No problems here. No idea what https access should have to do with dnssd printer browsing.
Comment by György Balló (City-busz) - Sunday, 05 August 2012, 04:08 GMT
The problem is that if I access the web admin interface by IP address, and I try to add or edit a printer, it redirects me:

"Upgrade Required

You must access this page using the URL https://<yourhostname>.local:631/admin/.";

And without the patch, I get:

"Bad Request"
Comment by György Balló (City-busz) - Sunday, 05 August 2012, 04:59 GMT
Here is the upstream report: http://www.cups.org/str.php?L4156
Comment by Andreas Radke (AndyRTR) - Sunday, 05 August 2012, 08:03 GMT
Subscribed to the bug.

But again, I have no problem accessing the remote server admin pages from my clients.
Comment by Andreas Radke (AndyRTR) - Sunday, 05 August 2012, 08:31 GMT
Patch applied. Please test 1.6.1-2 in extra.
Comment by György Balló (City-busz) - Sunday, 05 August 2012, 09:41 GMT
It works well. Thanks!

Loading...