Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30942 - [kdelibs3] can't be built on a current arch system

Attached to Project: Arch Linux
Opened by schreiberstein (schreiberstein) - Tuesday, 31 July 2012, 15:11 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 06 October 2012, 22:20 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
The package "kdelibs3" can't be built on a current arch system because autoconf/automake can't generate proper makefiles. (As far as I can tell)

Additional info:
Version : kdelibs 3.5.10-13

I attached a logfile, which is the result of "makepkg | tee log". (Mirror : http://pastebin.com/LtsjjQK7)
Build was done inside a clean chroot (created with pacstrap, using [testing] repo, x86_64).
I started a thread at Arch' BBS : https://bbs.archlinux.org/viewtopic.php?id=146129

Steps to reproduce:
Copy sources (PKGBUILD + patches) from ABS to your home directory and cd into it, then run makepkg.
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 06 October 2012, 22:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  I added a patch to fix the cups 1.6 build issue. The others I can't reproduce.
Comment by Eric Belanger (Snowman) - Tuesday, 31 July 2012, 21:37 GMT
I can't reproduce the autoconf/automake errors. Do you have base-devel installed in your chroot?

kdelibs3 doesn't build here but it's because of cups 1.6: https://bugs.kde.org/show_bug.cgi?id=304127
Comment by schreiberstein (schreiberstein) - Tuesday, 31 July 2012, 22:00 GMT
Yes, I installed base-devel.
A few moments ago I set up another chroot, this time without using [testing] repo. Same problem.
Could you please try it out inside a fresh chroot (x86_64)? Maybe it only works on your system.
How I did it :
-------------------------------
sudo pacman -S arch-install-scripts
cd ~/
mkdir my_chroot
sudo pacstrap -d ./my_chroot base base-devel
sudo arch-chroot ./my_chroot
adduser chroot ...
sudo pacman -S sudo abs
*add chroot to /etc/sudoers
abs
su chroot
cp -Rv /var/abs/extra/kdelibs3 ./
cd kdelibs3
makepkg -s
-------------------------------

Thanks in advance! :-)

Comment by Eric Belanger (Snowman) - Wednesday, 01 August 2012, 05:18 GMT
try with extra-x86_64-build (it's in devtools package). That's what I use and it's much simpler:
cd kdelibs3
sudo extra-x86_64-build
Comment by schreiberstein (schreiberstein) - Wednesday, 01 August 2012, 10:18 GMT
Thanks for the hint!
Unfortunately it fails because of the same reason. That's really odd :-(
Any idea?

Loading...