Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30921 - [xorg-server] segfaults

Attached to Project: Arch Linux
Opened by Gene (GeneC) - Monday, 30 July 2012, 12:29 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 28 December 2012, 10:31 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: X server (/usr/bin/X) crashes with Segmentation fault)


Additional info: Started happening sometime in the last few weeks - around the time of the upgrade to 3.5.0 kernel. Occurs randomly - no obvious trigger event. Laptop with intel ivy bridge i7 - using on board intel graphics (i915 driver). I am using testing repo and am fully updated.

* package version(s)
xorg-server 1.12.3-1
xf86-video-intel 2.20.2-2
linux 3.5-1



* config and/or log files etc.
[224200.821]
[224200.821] Backtrace:
[224200.821] 0: /usr/bin/X (xorg_backtrace+0x36) [0x560306]
[224200.821] 1: /usr/bin/X (0x400000+0x164039) [0x564039]
[224200.821] 2: /lib/libpthread.so.0 (0x7f1daaf53000+0xf170) [0x7f1daaf62170]
[224200.821] 3: /usr/bin/X (XIChangeDeviceProperty+0x1b8) [0x502d58]
[224200.821] 4: /usr/bin/X (0x400000+0x1033b3) [0x5033b3]
[224200.821] 5: /usr/bin/X (0x400000+0x34531) [0x434531]
[224200.821] 6: /usr/bin/X (0x400000+0x23615) [0x423615]
[224200.821] 7: /lib/libc.so.6 (__libc_start_main+0xf5) [0x7f1da9e02725]
[224200.822] 8: /usr/bin/X (0x400000+0x238ed) [0x4238ed]
[224200.822]
[224200.822] Segmentation fault at address 0x11
[224200.822]
Fatal server error:
[224200.822] Caught signal 11 (Segmentation fault). Server aborting
[224200.822]


Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 28 December 2012, 10:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  the initial reported bug is fixed. other reports are related to different hardware or different bugs. please open new tasks if needed.
Comment by Gene (GeneC) - Monday, 30 July 2012, 12:43 GMT
Bah - its not ivy bridge - its the older one .. Sandy Bridge ..

Also when it happens - X session is closed and I am kicked back to the kdm prompt. No evidence of any kernel space issues.
Comment by Andreas Radke (AndyRTR) - Monday, 30 July 2012, 14:38 GMT
You may want to try a different acceleration method and maybe LTS kernel. Then get in contact with upstream and try to find a solution.
Comment by Gene (GeneC) - Tuesday, 31 July 2012, 03:22 GMT
Ok thanks for suggestion.

I turned on SNA AccelMethod - even tho it's marked as experimental from intel (see http://intellinuxgraphics.org/2012.07.html)
I'll report back.

Comment by Gene (GeneC) - Tuesday, 31 July 2012, 03:49 GMT
SNA has problems - within a few mins - my 2nd kde panel has gone from solid color to black and white stripes in boxes ... something def not right.
Comment by Gene (GeneC) - Friday, 03 August 2012, 15:13 GMT
I have not had a crash yet using SNA - i of course continue to get screen corruptions - parts of the screen - like a terminal window or a panel - forcing that area to refresh cleans up the screen corruption. This never happened with the default AccelMethod (uxa ?).

This does indeed point to the driver as the source of X server SEGV tho it is not conclusive evidence ... not familiar with e server code at all so no idea if this makes sense or not.
Comment by Gene (GeneC) - Tuesday, 07 August 2012, 16:29 GMT
I just got a SEGV using the SNA driver - same traceback as before - so it seems the bug is not driver related (or at least if it is then its in both sna and uxa versions).

since sna is causing screen corruptions - i will now switch back to UXA.

Comment by Andreas Radke (AndyRTR) - Thursday, 09 August 2012, 15:50 GMT
anything in your dmesg?

You'd better get in touch with upstream. best place should be the intel mailing list first. This could be kernel drm, xorg driver related or even mesa's dri issue.
Comment by Andreas Radke (AndyRTR) - Sunday, 09 September 2012, 12:18 GMT
Status?
Comment by Ayr0 (ayr0) - Sunday, 23 September 2012, 04:13 GMT
I get the same type of crashes. It happens with both UXA and SNA acceleration. These crashes have been happening ever since I upgraded to xf86-video-intel 2.20.5. I'm tempted to downgrade my intel driver. I'd love to be running the latest driver, but not if it is crashing a lot.
Comment by Greg (dolby) - Monday, 15 October 2012, 04:12 GMT
Status with latest xorg server? Is there a bug report in the upstream bug tracker for this?
Comment by Greg (ripspin) - Thursday, 18 October 2012, 14:43 GMT
I installed Arch linux today and I get seg faults when I test start X, as per installation guide, error log attached.
So I have NO X.
I tested as root and user, standard video (Mainboard EliteGroup 661FX M).
Comment by Greg (ripspin) - Thursday, 18 October 2012, 15:12 GMT
The driver is: xf86-video-sis for: I installed Arch linux today...
Comment by Stefan Förster (HotblackDesiato) - Sunday, 21 October 2012, 15:30 GMT
I have the same bug on my IBM Thinkpad T23. I made a larger update of the system today. I experienced (amongst some other problems) a segmentation fault in xorg-server. Manual downgrading to 1.12.4-1 helped as a temporary workaround.

The video driver is "xf86-video-savage".

[ 73.795] (EE)
[ 73.795] (EE) Backtrace:
[ 73.795] (EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0x81e46a9]
[ 73.795] (EE) 1: /usr/bin/X (0x8048000+0x1a0596) [0x81e8596]
[ 73.795] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb76ea40c]
[ 73.795] (EE) 3: /usr/lib/libpixman-1.so.0 (0xb754a000+0x63fb3) [0xb75adfb3]
[ 73.795] (EE) 4: /usr/lib/libpixman-1.so.0 (0xb754a000+0x64432) [0xb75ae432]
[ 73.795] (EE) 5: /usr/lib/libpixman-1.so.0 (0xb754a000+0x52090) [0xb759c090]
[ 73.795] (EE) 6: /usr/lib/libpixman-1.so.0 (0xb754a000+0x522dd) [0xb759c2dd]
[ 73.795] (EE) 7: /usr/lib/libpixman-1.so.0 (pixman_fill+0x5d) [0xb75501dd]
[ 73.795] (EE) 8: /usr/lib/xorg/modules/libfb.so (fbFill+0x2f9) [0xb6f42aa9]
[ 73.795] (EE) 9: /usr/lib/xorg/modules/libfb.so (fbPolyFillRect+0x1b4) [0xb6f432d4]
[ 73.796] (EE) 10: /usr/bin/X (0x8048000+0x11e37b) [0x816637b]
[ 73.796] (EE) 11: /usr/lib/xorg/modules/libshadowfb.so (0xb6f25000+0x2037) [0xb6f27037]
[ 73.796] (EE) 12: /usr/bin/X (miPaintWindow+0x266) [0x81c3d36]
[ 73.796] (EE) 13: /usr/bin/X (miWindowExposures+0xbe) [0x81c3e7e]
[ 73.796] (EE) 14: /usr/bin/X (MapWindow+0x359) [0x80a94b9]
[ 73.796] (EE) 15: /usr/bin/X (InitRootWindow+0x133) [0x80a9623]
[ 73.796] (EE) 16: /usr/bin/X (0x8048000+0x1f680) [0x8067680]
[ 73.796] (EE) 17: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0xb7327605]
[ 73.796] (EE) 18: /usr/bin/X (0x8048000+0x1fac9) [0x8067ac9]
[ 73.796] (EE)
[ 73.796] (EE) Segmentation fault at address 0xb6f25000
[ 73.796]
Fatal server error:
[ 73.796] Caught signal 11 (Segmentation fault). Server aborting
Comment by Greg (dolby) - Saturday, 17 November 2012, 08:48 GMT
@HotblackDesiato: That should be a different issue. Please make a seperate bug report, most importantly to the xorg driver developers.

Loading...