Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30908 - LVM on dmcrypt (LUKS) not activated after boot

Attached to Project: Arch Linux
Opened by Johannes Schmidtke (crossblade1980) - Sunday, 29 July 2012, 12:58 GMT
Last edited by Tom Gundersen (tomegun) - Saturday, 04 August 2012, 11:31 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After a system upgrade the lvm on top of a cryptsetup is not activated
(status inactive)

encrypted root lvm is activated correctly but an additional LVM given in crypttab is not activated and thus logical partitions on top are not found.

Cryppttab unlocks partition with LVM on top correctly at boot.
LVM can be activated manually perfectly fine and is free of errors.


Happens under classic init scripts and systemd


Additional info:
Possible Packages:
bash-4.2.037-1 coreutils-8.17-3 dbus-1.6.4-1 dbus-core-1.6.4-1 filesystem-2012.7-1 gcc-libs-4.7.1-5 glib2-2.32.4-1 gnutls-3.0.21-2 grep-2.13-2 hwids-20120711-1 iana-etc-2.30-3 icu-49.1.2-2 initscripts-2012.07.5-1 kbd-1.15.3-3 libsystemd-187-2 linux-3.4.6-1 linux-api-headers-3.4.6-1 procps-ng-3.3.3-3 readline-6.2.004-1 systemd-187-2 systemd-tools-187-2 tzdata-2012d-1

most likely source initscripts-2012.07.5-1

Boot Log shows new:
Sun Jul 29 10:05:44 2012: Unlocking swap
Sun Jul 29 10:05:44 2012: Using legacy crypttab format. This will stop working in the future. See crypttab(5).
Sun Jul 29 10:05:44 2012: creating swapspace..
Sun Jul 29 10:05:44 2012: Unlocking decryptpool



Steps to reproduce:
downgrade to 15/07 solved problem - re upgrade reproduced it.
Multi layered device LVM on top of Luks on top of dmraid.
This task depends upon

Closed by  Tom Gundersen (tomegun)
Saturday, 04 August 2012, 11:31 GMT
Reason for closing:  Fixed
Comment by Matthias Dienstbier (fs4000) - Sunday, 29 July 2012, 15:50 GMT
 FS#30892  Duplicate?
Comment by Mathias Anselmann (matse) - Saturday, 04 August 2012, 10:33 GMT
Just tried transition from old init system to systemd (more or less because of #30892) with the same result as mentioned there - lvm is not activated with systemd. I don't think that the bug is directly related to #30892 since it occurs here with systemd, independently of having initscripts installed or not.
Comment by Tom Gundersen (tomegun) - Saturday, 04 August 2012, 10:41 GMT
@matse: Two solutions:

1) use initscripts in [testing]
2) keep using systemd and: create lvm-on-crypt.service in /etc/systemd/system, containing:

[Unit]
Description=LVM activation of encrypted devices
DefaultDependencies=no
Requires=systemd-udev-settle.service
After=systemd-udev-settle.service cryptsetup.target
Before=shutdown.target
Conflicts=shutdown.target

[Service]
ExecStart=/sbin/vgchange --sysinit --available y
Type=oneshot
TimeoutSec=0
RemainAfterExit=yes

[Install]
WantedBy=basic.target

And then do "systemctl enable lvm-on-crypt.service".

If you confirm that (2) works, then I'll try to add it to our lvm package.
Comment by Mathias Anselmann (matse) - Saturday, 04 August 2012, 11:16 GMT
@Tom: Great, I can confirm that both solutions work perfectly! Thanks for fast fixing these issues!
Comment by Tom Gundersen (tomegun) - Saturday, 04 August 2012, 11:31 GMT
Thanks for the feedback.

Loading...