Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#30877 - [systemd] 187-3 breaks automounting/mouting with GNOME 3

Attached to Project: Arch Linux
Opened by Dominik Cermak (Xerdomii) - Friday, 27 July 2012, 09:49 GMT
Last edited by Dave Reisner (falconindy) - Friday, 27 July 2012, 15:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


With systemd 187-3 devices are no longer automounted. After connecting a USB-Device simply nothing happens.
Also I can no longer mount devices with nautilus. Clicking on a device results in a error message like this:

Error mounting /dev/sdb1 at /run/media/xerdomii/QtMoko: Error spawning command-line `mount -t "ext3" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdb1" "/run/media/xerdomii/QtMoko"': Failed to execute child process "mount" (No such file or directory) (g-exec-error-quark, 8)

Downgrading to systemd 187-2 resolves this issue.
I don't know which specific package could be the problem as they are updated together: libsystemd, systemd, systemd-tools.

Please ask if something is missing.

Additional info:
* package version(s):
libsystemd 187-3
systemd 187-3
systemd-tools 187-3

* config and/or log files etc.
I have [testing] enabled, and am running systemd.

Steps to reproduce:
Boot into a system with systemd 187-3 and GNOME 3. Connect a USB-Device, or click on a not yet mounted device in nautilus.
This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 27 July 2012, 15:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  testing/systemd-187-4
Comment by Dominik Cermak (Xerdomii) - Friday, 27 July 2012, 10:02 GMT
Sorry, wrong project, I missed the switch because it is on the very top of the page and not in the report frame. It has to be 'Arch Linux'.
Edit: Thanks stephane for moving it.
Comment by Dominik Cermak (Xerdomii) - Friday, 27 July 2012, 10:28 GMT
I think this is because it wants to call 'mount' and because '--enable-split-usr' is not specified anymore it searches in '/usr/bin' but 'mount' actually is in '/bin'. From the help for this build flag: "Assume that /bin, /sbin aren't symlinks into /usr". So maybe the removal of this flag should be reverted because '/bin' and '/sbin' aren't symlinks to '/usr'.
Comment by Andreas Radke (AndyRTR) - Friday, 27 July 2012, 11:26 GMT
Same with netcfg. Breaks netcfg-service command to call "mkdir".
Comment by Zhengyu Xu (xzy3186) - Friday, 27 July 2012, 11:41 GMT
Not only the automount can not work under systemd 187-3. It seems to me the entire initscripts-systemd package (yes, entire means usr/lib/systemd/arch-modules-load, usr/lib/systemd/system/rc-local-shutdown.service, usr/lib/systemd/system-generators/arch-daemons and whatever belongs to this package) stop working after updating to systemd 187-3.

PS: At present initscripts-systemd installed on my laptop has a version 20120704.1-1