Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30840 - [linux] 3.5.x nouveau causes GPU lockup

Attached to Project: Arch Linux
Opened by WorMzy Tykashi (WorMzy) - Tuesday, 24 July 2012, 20:22 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 15 October 2012, 04:48 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Boot is successful, but X displays a static image made up from random artefacts from a previous X session and is unusable.

Boot messages include:
[ 1.410593] [drm] nouveau 0000:01:00.0: GPU lockup - switching to software fbcon

Additional info:
Linux 3.5 [in testing]

See attached verbose dmesg

Likely this bug reported upstream: https://bugs.freedesktop.org/show_bug.cgi?id=52244

Steps to reproduce:
Have kernel 3.5-1 installed on a system with a nvidia card (only tested with GTX 560 TI) and nouveau enabled.
   dmesg (312.2 KiB)
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 15 October 2012, 04:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux-3.6 in [testing]
Comment by Jelle van der Waa (jelly) - Friday, 27 July 2012, 10:28 GMT
We cant really do much as how it looks to me. So please report and help upstream track the bug and fix it.
Comment by John (graysky) - Monday, 06 August 2012, 02:56 GMT
I get a similar output in dmesg but not for nvidia hardware. I have an IvyBridge i7-3770K with iGPU (HD 4000).

Short version is here and full dmesg is attached.


$ dmesg | grep -i error
[ 1.957416] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20120320/psargs-359)
[ 1.957419] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT0._GTF] (Node ffff880409f82460), AE_NOT_FOUND (20120320/psparse-536)
[ 1.957442] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20120320/psargs-359)
[ 1.957445] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT1._GTF] (Node ffff880409f824d8), AE_NOT_FOUND (20120320/psparse-536)
[ 1.957999] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20120320/psargs-359)
[ 1.958004] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT0._GTF] (Node ffff880409f82460), AE_NOT_FOUND (20120320/psparse-536)
[ 1.958420] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20120320/psargs-359)
[ 1.958422] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT3._GTF] (Node ffff880409f825c8), AE_NOT_FOUND (20120320/psparse-536)
[ 1.959041] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20120320/psargs-359)
[ 1.959044] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT1._GTF] (Node ffff880409f824d8), AE_NOT_FOUND (20120320/psparse-536)
[ 1.960388] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20120320/psargs-359)
[ 1.960391] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT3._GTF] (Node ffff880409f825c8), AE_NOT_FOUND (20120320/psparse-536)
   dmesg (64.2 KiB)
Comment by Luc (luct) - Tuesday, 28 August 2012, 18:23 GMT
I have a similar situation with kernel version 3.5.3-1 and nouveau drivers. I have the same error in the original report, attached for completeness. Also for further bug testing please find attached a complete system report from HardInfo 0.5.1 (without benchmarks). Fixed by rolling back to kernel 3.4.7-1 for now.
Comment by O'car Campos (mann138) - Wednesday, 29 August 2012, 13:41 GMT
I have pretty much the same situation with kernel 3.5.3-1 and nouveau drivers. I have a gtx 560. I get this error after booting and an unusable screen because it keeps showing the messages attached in the file. I had boot into run level 3 to be able to roll back to previous kernel so I could work. Everything is fine with 3.4.7-1
Comment by WorMzy Tykashi (WorMzy) - Wednesday, 29 August 2012, 14:36 GMT
Could you guys post your respective logs on the upstream bug report, it's still stubbornly sat at the "NEEDINFO" stage, perhaps your information will be enough for the nouveau developers to debug the problem. It'd also show that it's affecting a greater number of users than just me and Kevin. :P
Comment by Luc (luct) - Wednesday, 29 August 2012, 15:02 GMT
Similar support for WorMxy's comment, reported upstream. For those having difficulty finding the specific bug (as I did):
https://bugs.freedesktop.org/show_bug.cgi?id=52244
Comment by Mike Cloaked (mcloaked) - Tuesday, 11 September 2012, 09:04 GMT
I have a nouveau system with the card NVIDIA Corporation G86M [Quadro FX 360M] (rev a1), and though it boots and runs (apparently) OK, however when I shutdown (after running KDE desktop with desktop effects switched on) I get a hang for some seconds after the x session ends, with a message on the console "GPU lockup - switching to software fbcon" which is the same as you have. I also notice that in my kernel log I have two lines:

Sep 11 09:37:35 localhost kernel: [ 389.092546] [drm] nouveau 0000:01:00.0: PFIFO_CACHE_ERROR - Ch 3/0 Mthd 0x0060 Data 0x8000000f
Sep 11 09:40:11 localhost kernel: [ 545.848393] [drm] nouveau 0000:01:00.0: PFIFO_CACHE_ERROR - Ch 3/5 Mthd 0x1b00 Data 0x00000000

The laptop continues to run and the screen appears normal - however I don't see the GPU lockup message in the logs - and only on the console during shutdown but this does look related to what you are all seeing?
Comment by Lubosz Sarnecki (lubosz) - Friday, 14 September 2012, 12:37 GMT
I suppose this is a related to these upstream bugs:
https://bugs.freedesktop.org/show_bug.cgi?id=53101
https://bugs.freedesktop.org/show_bug.cgi?id=53566

I guess the above bug was not marked as duplicate yet.

This commit caused a regression:

1a46098e910b96337f0fe3838223db43b923bad4 is the first bad commit
commit 1a46098e910b96337f0fe3838223db43b923bad4
Author: Ben Skeggs <bskeggs@redhat.com>
Date: Fri May 4 15:17:28 2012 +1000

drm/nvc0/ttm: use copy engines for async buffer moves

Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
Comment by Mike Cloaked (mcloaked) - Friday, 28 September 2012, 19:05 GMT Comment by WorMzy Tykashi (WorMzy) - Friday, 28 September 2012, 19:13 GMT
That's the bug report I included in the original bug report at the top of this page. :P
Comment by Mike Cloaked (mcloaked) - Friday, 28 September 2012, 19:19 GMT
Ah! Forgive my blindness! I hope that a new package will be available soon so that this can be resolved.
Comment by Lubosz Sarnecki (lubosz) - Saturday, 29 September 2012, 13:14 GMT
This issue was fixed upstream. You can use linux-nouveau-git. Did not test linux-mainline.
Comment by WorMzy Tykashi (WorMzy) - Saturday, 29 September 2012, 19:12 GMT
Can confirm that linux-nouveau-git works.
Comment by WorMzy Tykashi (WorMzy) - Monday, 01 October 2012, 10:01 GMT
Can also confirm that the problem is fixed in 3.6 proper, so this bug report can be closed now/when that kernel hits the repos.

Loading...