Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30809 - [python2-gobject2] trying to register gtype 'GMountMountFlags' as enum when it is of type 'GFlags'

Attached to Project: Community Packages
Opened by John Barranco (Mr_Kartoffelsalat.) - Monday, 23 July 2012, 01:05 GMT
Last edited by Jan Steffens (heftig) - Saturday, 20 October 2012, 09:01 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When starting batti the following warnings occur:
WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'
WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'
WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags

I'm not sure if this is also the reason why stalonetray gets broken when
tarting batti. (Batteryicon occurs in xxl, ignoring stalonetrays settings)

Additional info:
3.4.6-1-ARCH i686, xorg-server 1.12.3-1, Openbox 3.5.0-7, python2-dbus 1.1.1-1, hicolor-icon-theme 0.12-2, pygtk 2.24.0-3, upower 0.9.17-1, (notification-daemon 0.7.4-1)


Steps to reproduce:
Start batti in X from terminal emulator.


This task depends upon

Closed by  Jan Steffens (heftig)
Saturday, 20 October 2012, 09:01 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of  FS#30083 
Comment by John Barranco (Mr_Kartoffelsalat.) - Monday, 23 July 2012, 01:25 GMT
Pardon, I forgot to mention that it is batti 0.3.8-3 I am using.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Friday, 27 July 2012, 12:09 GMT
Hi, thanks for reporting. I just grepped the batti sourcecode and the strange thing is that the words "GFlags", "GMountMountFlags", "GDriveStartFlags" and "GSocketMsgFlags" is nowhere to be found.
A quick web search for "WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'" shows that this is probably a glib or pyobject bug instead.
More research is needed to find out which package to pin this one to.
Comment by Michael (goodwill) - Wednesday, 01 August 2012, 15:25 GMT Comment by Alexander F Rødseth (xyproto) (trontonic) - Thursday, 02 August 2012, 09:02 GMT
Thanks, Michael. Reassigning.
Comment by Reza Jelveh (rjzzleep) - Friday, 03 August 2012, 08:20 GMT Comment by Alexander F Rødseth (xyproto) (trontonic) - Tuesday, 07 August 2012, 00:00 GMT
Thanks, Reza. Guess we just have to wait for a new pygobject2 release from upstream, then.
Comment by Daniel Willard (dwillar) - Saturday, 06 October 2012, 05:40 GMT
I get all three errors when running
exo-open pkls
which opens pkls with medit
medit produces the error messages

there is a patch at http://bugzilla-attachments.gnome.org/attachment.cgi?id=209543
that has been applied at https://bugzilla.redhat.com/show_bug.cgi?id=790053
for Fedora that seem to fix the problem.

I think I have the dots connected but I don't know how to get this info to the
proper people for the Arch distro.

Please advise.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 15 October 2012, 18:44 GMT
The patches should be included in a release by upstream (the pygobject2 and gio? developers), then it will be fixed here. Arch Linux seldom have packages with patches, since we try to make upstream fix the problems instead.
Comment by Jan Steffens (heftig) - Wednesday, 17 October 2012, 09:33 GMT
pygobject2 should probably be bumped to a git snapshot, the 2.28 branch has some fixes.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Thursday, 18 October 2012, 15:47 GMT
Could pygobject2-devel do the trick? (it's 2.28.6-7)

Loading...