Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30781 - pacman requires rtmpdump?

Attached to Project: Arch Linux
Opened by Zsolt Udvari (uzsolt) - Saturday, 21 July 2012, 08:41 GMT
Last edited by Allan McRae (Allan) - Saturday, 21 July 2012, 09:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If I remove package "rtmpdump", pacman says:

# pacman
pacman: error while loading shared libraries: librtmp.so.0: cannot open shared object file: No such file or directory

Is it really pacman depends rtmpdump?
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 21 July 2012, 09:19 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Saturday, 21 July 2012, 08:55 GMT
Did you rebuild some packages against this library... e.g. curl?
Comment by Zsolt Udvari (uzsolt) - Saturday, 21 July 2012, 09:11 GMT
Yes, some packages are build via customizepkg, curl too.
Hm, I checked with readelf:
$ readelf -d /usr/lib/libcurl.so | grep rtmp
0x0000000000000001 (NEEDED) Shared library: [librtmp.so.0]

As I see it was my fault. I've added --without-librtmp to curl's configure and works pacman again.

Sorry :)

Loading...