Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30748 - [libvirt] [virt-manager] /usr/bin/nc vs. /usr/bin/nc.openbsd

Attached to Project: Community Packages
Opened by jstjohn (jstjohn) - Wednesday, 18 July 2012, 23:14 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 19 November 2012, 15:10 GMT
Task Type General Gripe
Category Upstream Bugs
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: I think that something needs to be done regarding the use of /usr/bin/nc vs. /usr/bin/nc.openbsd. When I try to connect to a remote RHEL server using qemu+ssh, I get a 'file not found' error and cannot connect because virt-manager is looking for /usr/bin/nc.openbsd which doesn't exist on the remote RHEL system. The comments for  FS#22068  suggested downloading 'gconf-editor' (which I didn't have already installed on my system), and appending `?netcat=/usr/bin/nc` to the qemu+ssh connection URI. This did work for me, but I don't feel that that is a satisfactory solution to the issue. That workaround isn't really feasible if you manage tens or hundreds of remote VM servers—a scenario I don't find too far fetched. I also don't think we should be required to symlink /usr/bin/nc.openbsd to /usr/bin/nc on the remote server. That's merely a band-aid for the underlying problem.

I propose that the libvirt and virt-manager package maintainers for Arch, RHEL, CentOS, Fedora, Debian, etc. come into agreement about what path should be used, and that patched packages meeting an agreed-upon standard get pushed out to the official repos for all distros. I'm guessing that this may not be the easiest thing to get done, and I would guess that a distro like RHEL has inflexible standards that it must follow, which means everyone else may need to replicate how they package these. Perhaps a better solution would be for *all* distros to standardize on using /usr/bin/nc OR for *all* distros to ship a symlink from /usr/bin/nc.openbsd to /usr/bin/nc. I much prefer the former.


Additional info:
* package versions: libvirt-0.9.13-2 and virt-manager-0.9.3-1 from [community]
* This is related to  FS#22068 , found here: https://bugs.archlinux.org/task/22068


Steps to reproduce:
* Try connecting via qemu+ssh to a remote RHEL server from an up-to-date Arch install.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 19 November 2012, 15:10 GMT
Reason for closing:  Fixed
Comment by Alexander F Rødseth (xyproto) (trontonic) - Friday, 20 July 2012, 10:12 GMT
Note that Arch has pretty inflexible standards too, it's the upstream version that normally should be used.
Comment by Greg (dolby) - Monday, 19 November 2012, 07:13 GMT
Wouldnt a dependency on gnu-netcat fix this?
If not adding a conflict with it and using nc as executable should work.
Comment by Sergej Pupykin (sergej) - Monday, 19 November 2012, 15:10 GMT
It looks like current libvirt version requires gnu netcat version. openbsd-netcat patch removed.

Loading...