Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30731 - separate group for usb devices

Attached to Project: Arch Linux
Opened by Radek Podgorny (rpodgorny) - Tuesday, 17 July 2012, 20:12 GMT
Last edited by Tom Gundersen (tomegun) - Wednesday, 18 July 2012, 23:42 GMT
Task Type Feature Request
Category System
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

i think it would be a good idea to have a separate group for usb devices which do not fall into camera/scanner/storage/... category. in my case i'm talking about a usbtiny mcu programmer and usb-connected oscilloscope but i'm sure there are gazillions of other devices.

sure i can add myself to "root" group and gain access to ALL devices but i think "usb" group would be a cleaner solution. as a side note, gentoo has it and it works pretty well... ;-)

thanks for considering it!
This task depends upon

Closed by  Tom Gundersen (tomegun)
Wednesday, 18 July 2012, 23:42 GMT
Reason for closing:  Upstream
Comment by Tom Gundersen (tomegun) - Wednesday, 18 July 2012, 07:32 GMT
Hm, I'm not too keen on adding custom groups. I'd suggest taking this suggestion upstream to systemd (which now contains udev, where all the standard rules are maintained). We spent quite some effort removing Archisms from the udev package, so I'd rather not add any back.

Does your device get assigned permissions via ACL (using consolekit or systemd), maybe it should? Does it come with some software package that could possibly ship its own udev rules?
Comment by Radek Podgorny (rpodgorny) - Wednesday, 18 July 2012, 10:09 GMT
well, the oscilloscope comes with a software (already in aur - openhantek) and its own udev rules. the problem is they set GROUP=plugdev which arch also doesn't have. i couldn't find a suitable equavalent so i've removed them altogether (so it now defaults to "root" group which is what i don't think is clean).

the programmer is a standard piece of "general purpose usb device with serial protocol" and does not come with any kind of software. it's used by avrdude but so is lots of other programmers and keeping udev rules for all of them (in avrdude package) would be insane...

...posted upstream (https://bugs.freedesktop.org/show_bug.cgi?id=52227), let's see what happens. ;-)
Comment by Tom Gundersen (tomegun) - Wednesday, 18 July 2012, 10:25 GMT
Ah, in that case, one option is to add the plugdev group in the AUR package.
Comment by Radek Podgorny (rpodgorny) - Wednesday, 18 July 2012, 11:44 GMT
yes. but i just didn't want to pollute people's systems with some one-use arbitrary group (on other distros plugdev group generally already exists and is used for roughly anything plugged into usb).

this is not really a technical problem. it's a policy problem. should or should not there be a "generic usb device that is not camera/scanner/storage/... group", that is the question. ;-)
Comment by Tom Gundersen (tomegun) - Wednesday, 18 July 2012, 11:45 GMT
Fair enough. Then the answer is: whatever upstream decides ;-)

Loading...