Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#30691 - [linux] 3.4.x Hotkeys are not recognized.

Attached to Project: Arch Linux
Opened by guillaume (yimm) - Sunday, 15 July 2012, 14:03 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 15 October 2012, 23:31 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



I have a clevo laptop (W150ERQ), and some hotkeys are not recognized like brightness and button to switch video card (optimus).
This problem seems to exist on others clevo laptop.
There is a bug report on launchpad which looks like my problem (

I tried steps #7 (, and I attached a file to this post.

When I set "acpi_osi=" in grub line, brightness hotkeys works, but optimus is broken.

What is the method in order to correct acpi ?
   dsdt.dsl (340.1 KiB)
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 15 October 2012, 23:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux has been updated
Comment by Madura A (maduraa) - Saturday, 04 August 2012, 05:54 GMT
I have a toshiba C660 and experiencing same behaviour, on this post on kernel bugzilla they've fixed it with a patch but it didn't show up in Arch repos yet. Please update Linux 3.4. Here's the buzilla link,