Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30690 - [linux, xorg] freeze when closing/opening lid

Attached to Project: Arch Linux
Opened by Felix Kaiser (fxkr) - Sunday, 15 July 2012, 13:14 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 31 January 2013, 19:23 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

After I close/open the laptop lid, the system freezes sometimes
(maybe 1 out of 5 times).

The screen will be black on the left side and show some black/white
vertical-stripes pattern on the right side (always the same pattern).
Always the same pattern.

Can't zap xorg via Ctrl-Alt-Backspace, can't switch to a different
VTY, but rebooting via Ctrl-Alt-Del works after a few tries.

I'm using a fresh installation on a Lenovo Thinkpad T430s
(Core i5-3320M (Ivy Bridge...), integrated Intel HD4000 GPU).


Additional info:
* package version(s): latest everything:

kernel 3.4.4-2
xorg-server 1.12.3-1
xf86-video-intel-sna 2.19.0-6
acpid 2.0.16-3
(not sure what's relevant)

* nothing noteworthy in kernel.log
* /var/log/everything.log:

...
Jul 15 14:33:34 localhost logger: LID closed
Jul 15 14:33:35 localhost logger: LID opened
Jul 15 14:33:35 localhost logger: LID closed
Jul 15 14:33:36 localhost logger: LID opened
Jul 15 14:33:40 localhost acpid: client 575[0:0] has disconnected
Jul 15 14:33:40 localhost acpid: client connected from 2102[0:0]
Jul 15 14:33:40 localhost acpid: 1 client rule loaded
Jul 15 14:33:45 localhost acpid: client 2102[0:0] has disconnected
Jul 15 14:33:51 localhost shutdown[2120]: shutting down for system reboot
Jul 15 14:33:52 localhost init: Switching to runlevel: 6
Jul 15 14:33:54 localhost shutdown[2130]: shutting down for system reboot
Jul 15 14:33:54 localhost acpid: exiting
Jul 15 14:33:54 localhost syslog-ng[452]: syslog-ng shutting down; version='3.3.5'

* happens regardless of wether or not acpid is running

Steps to reproduce:
- use a T430s, close lid, open lid, repeat a few times
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 31 January 2013, 19:23 GMT
Reason for closing:  Fixed
Comment by Felix Kaiser (fxkr) - Tuesday, 17 July 2012, 20:36 GMT
- Closing/opening the lid again after the error occurs doesn't help.

- And it turns out that it's just the display that doesn't work -- everything else works normally.
I can recover from the bug by suspending the laptop via a hotkey and waking it up again, after that the display will work normally again.
Comment by Fox Mulder (scullder) - Wednesday, 18 July 2012, 16:25 GMT
I've a similar problem with my T420s for several months and I recognize precisely the pattern which appears on your screen.
It also happens with my laptop once using suspend2ram.

But it happens more frequently if:

* I change the resolution of the screen (I've discovered this issue while playing with the settings of urban terror).
* I plug a screen on the vga port and try to configure it via kde tool (using xrandr?)

When the bug occurs, I can still blindly login with the root user in a tty and restart my laptop.

I'm using a IntelCore i5-2540M CPU (and integrated Intel HD Graphics 3000), it was happening with the old xf86-video-intel driver and it's still happening with xf86-video-intel-sna.

I've also noticed that after the reboot, my screen is "flickering", it reminds me of the effect of an old CRT screen with a low frequency. In oder to solve this problem, I have to do a magic combination of this 2 tasks:

* restart under MS Windows
and/or
* unplug the 2 batteries of my laptop, and wait

In relation to this bug, I've removed all the special parameters for the intel driver in my grub configuration on the kernel line.

I admit I don't know how to fill a good bug report for this issue ;)
Comment by Felix Kaiser (fxkr) - Wednesday, 18 July 2012, 18:53 GMT
Same symptoms in this old (fixed) T420s / Ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/812638

They also have a picture there ( https://launchpadlibrarian.net/75481075/IMG_20110718_182145.jpg ), and thats exactly the same pattern I see.
Comment by Felix Kaiser (fxkr) - Sunday, 05 August 2012, 13:11 GMT
Neither happens with a Fedora 17 live CD nor with a fully updated Fedora 17 installation.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Tuesday, 11 September 2012, 05:43 GMT
Is this still an issue? Thanks
Comment by Felix Kaiser (fxkr) - Tuesday, 11 September 2012, 06:49 GMT
Yes. I just tested it again and it still happens.
Comment by Thomas Bächler (brain0) - Tuesday, 11 September 2012, 07:05 GMT
Had this issue a long time ago. Nobody knew why. Intel guys came up with adding the following blacklist to the driver, but my laptop is still the only one on it, and I am not sure it was ever the correct solution:

https://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob;f=drivers/gpu/drm/i915/intel_lvds.c;h=e9a6f6aaed855dfa5acad6026c0f95e79a33955e;hb=HEAD#l482
Comment by Fox Mulder (scullder) - Tuesday, 11 September 2012, 20:07 GMT
I confirm that it's not fixed for me (3.5.3-1-ARCH)
Comment by Ari Pollak (ari) - Monday, 01 October 2012, 13:42 GMT
FWIW, I upgraded the BIOS to the latest from Lenovo on my T430s about 2 weeks ago, and I haven't had this problem since then. I'm still on the same kernel, 3.5.
Comment by Felix Kaiser (fxkr) - Thursday, 04 October 2012, 20:09 GMT
I just updated my BIOS and it still happens :(

Ari, could you maybe please run dmidecode so that we can be sure we are using the same BIOS now? Here's what it says for me:

[...]
Handle 0x000E, DMI type 0, 24 bytes
BIOS Information
Vendor: LENOVO
Version: G7ET60WW (2.02 )
Release Date: 09/11/2012
[...]
BIOS Revision: 2.2
Firmware Revision: 1.9
[...]
Comment by Fox Mulder (scullder) - Thursday, 04 October 2012, 21:24 GMT
I've also updated the BIOS of my t420s, and the problem still occurs when switching from 1600x900 to 640x480.

Handle 0x000F, DMI type 0, 24 bytes
BIOS Information
Vendor: LENOVO
Version: 8CET54WW (1.34 )
Release Date: 07/11/2012
Address: 0xE0000
Runtime Size: 128 kB
ROM Size: 8192 kB
[...]
BIOS Revision: 1.34
Firmware Revision: 1.20
Comment by Ari Pollak (ari) - Friday, 05 October 2012, 21:02 GMT
Handle 0x000E, DMI type 0, 24 bytes
BIOS Information
Vendor: LENOVO
Version: G7ET32WW (1.14 )
Release Date: 07/31/2012
Address: 0xE0000
Runtime Size: 128 kB
ROM Size: 16384 kB
Characteristics:
PCI is supported
PNP is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
EDD is supported
3.5"/720 kB floppy services are supported (int 13h)
Print screen service is supported (int 5h)
8042 keyboard services are supported (int 9h)
Serial services are supported (int 14h)
Printer services are supported (int 17h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
BIOS boot specification is supported
Targeted content distribution is supported
UEFI is supported
BIOS Revision: 1.14
Firmware Revision: 1.8
Comment by Greg (dolby) - Saturday, 17 November 2012, 09:52 GMT
Still a problem with 3.6.6?
Comment by Nathan Typanski (ndat) - Friday, 11 January 2013, 00:54 GMT
Still a problem for me.
Comment by Tobias Powalowski (tpowa) - Wednesday, 23 January 2013, 14:58 GMT
Still an issue with 3.7.x?
Comment by Felix Kaiser (fxkr) - Saturday, 26 January 2013, 18:06 GMT
Nope. Just tested closing/opening the lid a number of times and I can't reproduce it anymore. Awesome!

% pacman -Qs xf86-video-intel
local/xf86-video-intel 2.20.19-1 (xorg-drivers xorg)
X.org Intel i810/i830/i915/945G/G965+ video drivers
% pacman -Qs "^linux$"
local/linux 3.7.4-1 (base)
The linux kernel and modules
Comment by Nathan Typanski (ndat) - Thursday, 31 January 2013, 16:29 GMT
No longer a problem for me with 3.7.4-1 either.

Edit: just kidding. My laptop just failed to suspend before I lugged it off on the way to class. The fan seems to turn off and CPU bumps up to 100% when it does this, so the sucker nearly cooked to death in my backpack.

T420 Lenovo with Nvidia NVS4200M and an Intel 2.7GHz Core 2. 8GB RAM.

Loading...