Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30673 - [gcc-libs-multilib] Unable to install gcc-libs-multilib 4.7.1-4.1

Attached to Project: Community Packages
Opened by ctxfi-user (ctxfi-user) - Saturday, 14 July 2012, 11:17 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 14 July 2012, 11:46 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Try installing gcc-libs-multilib gets me:

$ pacman -S gcc-libs-multilib
resolving dependencies...
warning: dependency cycle detected:
warning: lib32-gcc-libs will be installed before its gcc-libs-multilib dependency
looking for inter-conflicts...
:: gcc-libs-multilib and gcc-libs are in conflict. Remove gcc-libs? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: gcc: requires gcc-libs=4.7.1-4


Additional info:
* gcc 4.7.1-4
* to be installed gcc-libs-multilib 4.7.1-4.1 provides gcc-libs=4.7.1-4.1
* pacman 4.0.3-3


Steps to reproduce:
Try install or system update (with installed gcc-libs-multilib).
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 14 July 2012, 11:46 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Saturday, 14 July 2012, 11:25 GMT
pacman -S gcc-multilib
Comment by ctxfi-user (ctxfi-user) - Saturday, 14 July 2012, 11:41 GMT
Shame on me!!!

I just did it in the wrong way all the time. Though, I used gcc this way to compile my all time running VDR...

Got it now. Thanks. Solved. Sorry for the inconvenience.

Loading...