Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30640 - [os-prober] errors while running on dmraid system with windows

Attached to Project: Community Packages
Opened by Krzysztof Raczkowski (raku) - Wednesday, 11 July 2012, 15:21 GMT
Last edited by György Balló (City-busz) - Sunday, 08 September 2013, 19:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Timothy Redaelli (tredaelli)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I can't update grub configuration os system with dmraid and Windows.
When I run grub-mkconfig (or os-prober), I get:

grub-probe: error: unknown filesystem.
grub-probe: error: unknown filesystem.
rmdir: failed to remove '/var/lib/os-prober/mount': Device or resource busy

grub config for linux is working OK, but I can't generate config for running Windows 7.

* package version(s)
os-prober-1.53-1

Steps to reproduce:
just run os-prober on system with dmraid and Windows installed.
This task depends upon

Closed by  György Balló (City-busz)
Sunday, 08 September 2013, 19:03 GMT
Reason for closing:  No response
Additional comments about closing:  Probably fixed: http://savannah.gnu.org/bugs/?37073
Comment by Krzysztof Raczkowski (raku) - Sunday, 15 July 2012, 14:00 GMT
With os-prober-1.49-3 I was able to generate config for Windows 7.
Unfortunatelly I've lost my PC for a couple of weeks, so I can't give more feedback.
Comment by Timothy Redaelli (tredaelli) - Tuesday, 17 July 2012, 13:36 GMT
Can you try to retest with 1.49-3?
http://ompldr.org/vZXJzeQ or http://ompldr.org/vZXJzeg
Comment by Krzysztof Raczkowski (raku) - Tuesday, 17 July 2012, 13:40 GMT
As I wrote above - config for Windows 7 with 1.49-3 was correct. I had this version in my pacman cache and already did a downgrade.
Comment by Krzysztof Raczkowski (raku) - Monday, 27 August 2012, 20:43 GMT
Hi,
I've just got my PC back. I've managed to make it up-to-date. Here's a result of my tests:

os-prober-1.49-3
$ LC_ALL=C sudo os-prober
Password:
/dev/mapper/isw_debfgejdjb_Volume0p1:Windows 7 (loader):Windows:chain

os-prober-1.54-1
$ LC_ALL=C sudo os-prober
grub-probe: error: unknown filesystem.
grub-probe: error: unknown filesystem.
rmdir: failed to remove '/var/lib/os-prober/mount': Device or resource busy

Looks like 1.54-1 still hits this bug.
Comment by Krzysztof Raczkowski (raku) - Sunday, 09 September 2012, 14:38 GMT
The same with os-prober 1.55-1:
LC_ALL=C sudo os-prober
grub-probe: error: unknown filesystem.
grub-probe: error: unknown filesystem.
rmdir: failed to remove '/var/lib/os-prober/mount': Device or resource busy
Comment by György Balló (City-busz) - Sunday, 08 September 2013, 03:01 GMT
Is this still a problem with latest grub and os-prober?
Comment by Krzysztof Raczkowski (raku) - Sunday, 08 September 2013, 18:50 GMT
I'm no longer using Archlinux.

Loading...