Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30628 - [bitcoin-qt] crashes when using invalid locale

Attached to Project: Community Packages
Opened by Heine Laursen (Zann) - Tuesday, 10 July 2012, 18:26 GMT
Last edited by Alexander F Rødseth (xyproto) (trontonic) - Sunday, 15 July 2012, 12:48 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Timothy Redaelli (tredaelli)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

bitcoin-qt crashes upon start. I'm on i686 architecture, so I'm not sure if the same happens on x86_64 architecture.

$ bitcoin-qt

(process:28841): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
terminate called after throwing an instance of 'std::runtime_error'
what(): locale::facet::_S_create_c_locale name not valid
Aborted

$ pacman -Si bitcoin-qt
Repository : community
Name : bitcoin-qt
Version : 0.6.3-1

Not sure what else to report.
This task depends upon

Closed by  Alexander F Rødseth (xyproto) (trontonic)
Sunday, 15 July 2012, 12:48 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Please reopen if this is still an issue after fixing the locale issues.
Comment by Dave Reisner (falconindy) - Tuesday, 10 July 2012, 18:52 GMT
What does 'locale' and 'locale -a' report?
Comment by Heine Laursen (Zann) - Thursday, 12 July 2012, 12:42 GMT
Output of locale
$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_GB.utf8
LC_CTYPE="en_GB.utf8"
LC_NUMERIC=da_DK.utf8
LC_TIME=da_DK.utf8
LC_COLLATE="en_GB.utf8"
LC_MONETARY=da_DK.utf8
LC_MESSAGES="en_GB.utf8"
LC_PAPER="en_GB.utf8"
LC_NAME="en_GB.utf8"
LC_ADDRESS="en_GB.utf8"
LC_TELEPHONE="en_GB.utf8"
LC_MEASUREMENT=da_DK.utf8
LC_IDENTIFICATION="en_GB.utf8"
LC_ALL=

Output of locale -a
$ locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
da_DK.utf8
en_US.utf8
nb_NO.utf8
Comment by Dave Reisner (falconindy) - Thursday, 12 July 2012, 12:57 GMT
So fix your locales. Rerun 'locale-gen' as root.
Comment by Heine Laursen (Zann) - Thursday, 12 July 2012, 13:09 GMT
What do you mean fix locales? I've run local-gen as root.
loged out and back in again. Still i get:


$ bitcoin-qt

(process:30695): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
terminate called after throwing an instance of 'std::runtime_error'
what(): locale::facet::_S_create_c_locale name not valid
Aborted
Comment by Dave Reisner (falconindy) - Thursday, 12 July 2012, 13:26 GMT
Do you have any locales enabled in /etc/locale.gen? This isn't a bitcoin problem.
Comment by Heine Laursen (Zann) - Thursday, 12 July 2012, 14:37 GMT
Yes i have.

# locale-gen
Generating locales...
da_DK.UTF-8... done
en_US.UTF-8... done
nb_NO.UTF-8... done
Generation complete.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Sunday, 15 July 2012, 12:45 GMT
You seem to depend on "en_GB.utf8" while not having enabled "en_GB.utf8" in /etc/locale.gen, only da_DK.utf8, en_US.utf8 and nb_NO.utf8.
Enable en_GB.utf8 in locale.gen and regenerate or change the values of LANG etc.

Loading...