Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30616 - [audacity] rebuild against ffmpeg-compat or patch audacity

Attached to Project: Arch Linux
Opened by Uli (Army) - Monday, 09 July 2012, 15:49 GMT
Last edited by Eric Belanger (Snowman) - Wednesday, 08 August 2012, 01:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

Within audacity you can view a log file which show the following after startup

05:42:43 PM: Audacity 2.0.1
05:42:44 PM: Trying to load FFmpeg libraries...
05:42:44 PM: Trying to load FFmpeg libraries from system paths. File name is 'libavformat.so.53'.
05:42:44 PM: Checking for monolithic avformat from 'libavformat.so.53'.
05:42:44 PM: Error: libavformat.so.53: cannot open shared object file: No such file or directory
05:42:44 PM: Loading avutil from 'libavutil.so.51'.
05:42:44 PM: Loading avcodec from 'libavcodec.so.53'.
05:42:44 PM: Error: libavcodec.so.53: cannot open shared object file: No such file or directory
05:42:44 PM: Loading avformat from 'libavformat.so.53'.
05:42:44 PM: Error: libavformat.so.53: cannot open shared object file: No such file or directory
05:42:44 PM: Error: Failed to load FFmpeg libraries.
05:42:44 PM: Error: Failed to find compatible FFmpeg libraries.

Audacity doesn't crash or anything, but I guess there's functionality missing.

It fails to build against ffmpeg with those last lines http://codepad.org/I8cdp6y7

Maybe there's already a patch for audacity, I haven't looked that up yet. If not, audacity should be rebuilt, so it uses ffmpeg-compat. Since audacity is in [extra] and ffmpeg-compat is in [community], there should be a move then.

Additional info:
* package version(s)

% pacman -Qi audacity
Name : audacity
Version : 2.0.1-1

% pacman -Qi ffmpeg
Name : ffmpeg
Version : 1:0.11.1-1

% pacman -Qi ffmpeg-compat
Name : ffmpeg-compat
Version : 20120509-1

* config and/or log files etc.

See the description

Steps to reproduce:

Start audacity and open the log file ("Help" -> "Show Log...")
This task depends upon

Closed by  Eric Belanger (Snowman)
Wednesday, 08 August 2012, 01:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  audacity-2.0.1-2 uses ffmpeg-compat
Comment by Andrea Scarpino (BaSh) - Monday, 09 July 2012, 17:53 GMT
I'm trying to patch it.

Anyway, a third option is to disable the ffmpeg plugin:
http://code.google.com/p/cuberok/issues/detail?id=60#c1
Comment by Uli (Army) - Monday, 09 July 2012, 18:28 GMT
Ok, I haven't thought about this option :D
Comment by Eric Belanger (Snowman) - Monday, 09 July 2012, 18:38 GMT
I'm also currently working on it. I was thinking of using audacity's version of ffmpeg (--with-ffmpeg=local) until we get a patch.
Comment by Eric Belanger (Snowman) - Tuesday, 31 July 2012, 23:04 GMT
Andrea: Any success coming up with a patch? You can take more time to work on it if you're busy.

BTW, using --with-ffmpeg=local doesn't work. I thought it would use a bundled copy of ffmpeg to build it statically but instead it only uses a couple of bundled headers.
Comment by Stefano Cipriani (cip91) - Monday, 06 August 2012, 17:21 GMT
A temporary workaround:

- Downgrade ffmpeg to 20120509-1 (This should be the latest working package. If you don't know how to downgrade:
https://wiki.archlinux.org/index.php/Downgrading_Packages
I recommend using the Arch Rollback Machine to retrieve the package)

- Audacity now crash on loading libx264, so link /usr/lib/x264.so to /usr/lib/x264.so.x (x is a number, you can see which number you need in the Audacity log)
( for me the command was # ln -s libx264.so libx264.so.120 )

Hope this helps (:

EDIT: If you don't want to use symlinks you can downgrade package x264 installing x264-20120204-1 (it contains x264.so.120)
Comment by Andrea Scarpino (BaSh) - Monday, 06 August 2012, 18:29 GMT
I completely forgot about this, but I couldn't work on it anyway.

@Eric
please disable the ffmpeg option or rebuild using ffmpeg-compat.

@Stefano
symbolink links are evil.

Loading...