Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30615 - [kdemultimedia-kmix] "Mute" checkbox is never checked

Attached to Project: Arch Linux
Opened by Andrew D. (andrewd18) - Monday, 09 July 2012, 14:04 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 15 October 2012, 23:32 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ronald van Haren (pressh)
Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
This is a really really minor quibble but I've had it for a few versions of KDE and figured I'd report it. The Kmix icon in the taskbar changes to reflect the state of my audio hardware, either muted or not muted. However, the "Mute" menu option in Kmix's right-click menu does not.

See attached screenshots.

In "kmix_sound_unmuted.png" you can see that the icon in the tray shows unmuted, and the mute box is unchecked. Looks good.
In "kmix_sound_muted.png" you can see that the icon in the tray shows muted, but the mute box is still unchecked. Confusing.



Additional info:
* Using extra/kdemultimedia-kmix 4.8.4-2

Relevant lspci -v:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: Sony Corporation Device 9035
Flags: bus master, fast devsel, latency 0, IRQ 48
Memory at d5200000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel



Steps to reproduce:
1. Log into KDE.
2. Right-click the Kmix icon in the taskbar.
3. Select Mute. The sound mutes and the Kmix icon changes to be grayed out.
4. Right-click the Kmix icon in the taskbar.

Expected:
* The Mute checkbox should be checked, as the sound is muted.

Actual:
* The Mute checkbox is not checked. Clicking it does unmute sound, as expected, however.
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 15 October 2012, 23:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  In kdemultimedia-kmix-4.9.2-1
Comment by Jelle van der Waa (jelly) - Saturday, 21 July 2012, 18:38 GMT
Please report it upstream
Comment by Andrew D. (andrewd18) - Monday, 23 July 2012, 21:46 GMT
This apparently has already been reported and assigned, per https://bugs.kde.org/show_bug.cgi?id=298146.

Loading...