Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30605 - [seahorse] Not importing GPG-Keys

Attached to Project: Arch Linux
Opened by Michael Berg (jk799) - Sunday, 08 July 2012, 23:17 GMT
Last edited by Allan McRae (Allan) - Friday, 16 November 2012, 11:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When i try to import a remote gpg key with seahorse, i get search results, click on "import" and simply nothing happens. tried with many keys.

enigmail with thunderbird worked fine before, maybe this locked something?

i wanted to use evolution instead of thunderbird, but this is a kind of a blocker :-(

seahorse is on version 3.4.1.
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 16 November 2012, 11:56 GMT
Reason for closing:  No response
Additional comments about closing:  Also, probably not a bug...
Comment by Ionut Biru (wonder) - Sunday, 08 July 2012, 23:53 GMT
importing works fine here, enigmail as well with thunderbird.
Comment by Michael Berg (jk799) - Tuesday, 10 July 2012, 13:15 GMT
strange, i can reproduce this behaviour on three different installations.
what is happening when you select a key from the search results (from remote -> get remote key (German locale: "Entfernt -> Entfernte Schl├╝ssel suchen")), rightclick and click "import"? should there be a dialog or something?
Comment by Jelle van der Waa (jelly) - Saturday, 28 July 2012, 13:44 GMT
It sure works. But seahorse doesn't display the key, after importing allan mcrea's key I ran:

gpg --list-keys

Which printend allan's key. So seahorse works.
Comment by Jelle van der Waa (jelly) - Saturday, 04 August 2012, 21:10 GMT
any update?
Comment by Damien Robert (Gondolin) - Wednesday, 29 August 2012, 10:12 GMT
By default, seahorse only show your personal keys. The import probably works fine, as gpg --list-keys will show you. You can also go to the view setting of seahorse to have it show your non personal keys.

Loading...