Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30588 - glibc: /lib existiert im Dateisystem

Attached to Project: Arch Linux
Opened by Michael H. (glako) - Saturday, 07 July 2012, 15:08 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 07 July 2012, 16:23 GMT
Task Type Support Request
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
Systemupgrade with pacman -Syu: only glibc should be upgraded but fails with "glibc: /lib existiert im Dateisystem"

Installed Version: glibc 2.16.0-1
New Version: glibc 2.16.0-2

Steps to reproduce:
pacman -Syu
(testing activated)
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 07 July 2012, 16:23 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Saturday, 07 July 2012, 15:15 GMT
Oh come on... a cursory scan of /lib would show you why this fails

pacman -Qo /lib/*
Comment by Ionut Biru (wonder) - Saturday, 07 July 2012, 15:36 GMT
you have lib32-glibc installed but don't have activated multilib-testing?
Comment by Michael H. (glako) - Saturday, 07 July 2012, 16:09 GMT
pacman -Qo /lib/* -> see attachment
Also there's a output of ls -l /lib

It's almost the same, except the symlinks.
Tried to move the files -> failed

No lib32-glibc installed.
Comment by Dave Reisner (falconindy) - Saturday, 07 July 2012, 16:10 GMT
Fehler: Kann die Eigentumsrechte am Verzeichnis '/lib/modprobe.d' nicht bestimmen
Fehler: Kann die Eigentumsrechte am Verzeichnis '/lib/modules' nicht bestimmen

Yes, that would be the problem... clean up whatever files reside in those directories and remove them.
Comment by Michael H. (glako) - Saturday, 07 July 2012, 16:18 GMT
Great! Thanks!

Sorry for the wrong Bugreport!

Loading...