Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30587 - [Testing] Glibc-2.16.0-2 busted my installation.

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Saturday, 07 July 2012, 13:43 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 07 July 2012, 14:07 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: Hello.

I upgraded a few minutes ago my archlinux + testing installation. As I cannot install glibc (because of some AUR software which had links or binary in /lib), I made the mistake of forcing installation. My system is dead. I will try repairing using archboot on an USB key.

Maybe this version needs to be retired. Well I'm kinda annoyed by this bug :(


Additional info:
glibc-2.16.0-2


Steps to reproduce: just try to upgrade to this version of glibc with some software leaving binaries or links in it.
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 07 July 2012, 14:07 GMT
Reason for closing:  Not a bug
Additional comments about closing:  User error.
Comment by Dave Reisner (falconindy) - Saturday, 07 July 2012, 14:06 GMT
> Steps to reproduce: just try to upgrade to this version of glibc with some software leaving binaries or links in it.
AND use --force, which pushes you well into unsupported land.

What do you really expect anyone to do here? AUR packages are unsupported. It's nothing new that you need to take care of these yourself.

I just did this upgrade: I saw the file conflict, worked around it like a sane person without using --force, and it worked just fine.

Loading...