Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30574 - [dialog] opera's installer script broken since dialog update to 1.1_20120703

Attached to Project: Arch Linux
Opened by c (c) - Friday, 06 July 2012, 15:49 GMT
Last edited by Stéphane Gaudreault (stephane) - Friday, 06 July 2012, 20:40 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Stéphane Gaudreault (stephane)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
opera's installer script broken since dialog update to 1.1_20120703
Script (./install) hangs.

Additional info:
* 1.1_20120703


Steps to reproduce:

Download Opera i686 or x86_64 tar.xz, extract, cd opera-*, try ./install.
Tried with http://snapshot.opera.com/unix/marlin_12.50-1497/opera-next-12.50-1497.i386.linux.tar.xz and http://snapshot.opera.com/labs/spdy/Linux-FreeBSD/opera-labs-spdy-12.01-1495.i386.linux.tar.xz
This task depends upon

Closed by  Stéphane Gaudreault (stephane)
Friday, 06 July 2012, 20:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  20120706 in [testing].

Thanks Thomas for your quick answer.
Comment by Stéphane Gaudreault (stephane) - Friday, 06 July 2012, 16:25 GMT
Confirmed :

This command never return
dialog --msgbox "test test test " 100 100
Comment by Stéphane Gaudreault (stephane) - Friday, 06 July 2012, 16:35 GMT
Forwarded upstream.

I removed the package from [testing] until I get a fix for this bug.
Comment by Thomas Dickey (dickey) - Friday, 06 July 2012, 16:55 GMT
The problem is from deleting too many lines when I reorganized the mouse-click code.
This chunk is missing from msgbox.c around line 155:

case DLGK_ENTER:
result = dlg_ok_buttoncode(button);
break;

(I'll review a little more, and update the ftp this afternoon).
Comment by Thomas Dickey (dickey) - Friday, 06 July 2012, 18:59 GMT
2012/07/06
+ modify samples/setup-tempfile to work with Tru64's shell.
+ modify inputmenu sample scripts to make them more portable:
+ use "id" rather than "$GROUPS", use sed to work with Solaris.
+ use sed to split-up the rename results to work with HPUX.
+ fix regression in msgbox (ArchLinux #30574)

Loading...