Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30568 - [ntfs-3g] mount.ntfs-3g randomly exits for read-and-write ntfs volumes

Attached to Project: Arch Linux
Opened by Spartan Roc (spartanroc) - Friday, 06 July 2012, 13:47 GMT
Last edited by Tom Gundersen (tomegun) - Tuesday, 13 November 2012, 13:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:

I did a full system upgrade (pacman -Syu) a couple of weeks ago. I have two ntfs volumes mounted using ntfs-3g. One is ready-only and seldomly used so it's been working fine. But the other more intensively used read-and-write volume got dismounted randomly. Once it happens, the error message is 'transport endpoint is disconnected' and the corresponding process mount.ntfs-3g got killed (the process for the readonly volume is fine). It usually happens after one or two days of use. It can happens when the machine sitting idly.

Additional info:
* package version(s)
extra/ntfs-3g 2012.1.15-3

* config and/or log files etc.
options for read-only volume: defaults,ro,locale=en_US.utf8,umask=007,gid=95
options for read-and-write volume: defaults,locale=en_US.utf8,umask=007,uid=1000,gid=95

Steps to reproduce:
can happen anytime. ususally after one or two days of use.
This task depends upon

Closed by  Tom Gundersen (tomegun)
Tuesday, 13 November 2012, 13:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  Appears to be fixed. Please reopen otherwise.
Comment by Jelle van der Waa (jelly) - Friday, 27 July 2012, 10:32 GMT
Assigned it to the latest packager? Tom is this your package if so please adopt it in archweb :)
Comment by Alex Forencich (alex.forencich) - Thursday, 16 August 2012, 13:44 GMT
This issue is affecting a couple more people (myself included). This is likely a regression; ntfs support in arch was not always broken.

See forum post: https://bbs.archlinux.org/viewtopic.php?pid=1147302
Comment by Jason Van Wynsberg (jasonvw) - Monday, 20 August 2012, 02:13 GMT
This issue seems to occur on x64 as well. Downgrading NTFS-3g to 2012.1.15-1 seems to resolve the problem for now.
Comment by Alex Forencich (alex.forencich) - Monday, 20 August 2012, 02:15 GMT
Actually, I just got nailed by this issue while running 2012.1.15-1, so I downgraded another version to 2011.4.12-1. We'll see if that fixes the problem or not. And I'm running x64.
Comment by Alex Forencich (alex.forencich) - Tuesday, 21 August 2012, 10:57 GMT
Well, 2011.4.12-1 does not work either. I just had ntfs-3g die on me again. I suppose I will keep going until I figure out when this bug was introduced.
Comment by Tom Gundersen (tomegun) - Tuesday, 21 August 2012, 11:52 GMT
@Jelle: not mine, never used this stuff.

@Alex: if you are able to figure something out, please let me know and I'll see what I can do.
Comment by Alex Forencich (alex.forencich) - Wednesday, 22 August 2012, 06:19 GMT
Crashed on 2011.1.15-1 as well. Does any method exist to look at the output/error messages generated by ntfs-3g, especially when it crashes? Also, I managed to unmount it this time without rebooting for some reason. Usally there is still something left using the device and linux doesn't let me unmount it until I reboot it. If I could remount it without a classic windows solution, this issue would not be nearly as problematic.
Comment by Alex Forencich (alex.forencich) - Wednesday, 22 August 2012, 06:47 GMT
And crashed on 2010.10.2-1 as well.
Comment by Natanji (Natanji) - Wednesday, 26 September 2012, 08:47 GMT
Confirming this crash for 2012.1.15-3.
Comment by Alex Forencich (alex.forencich) - Wednesday, 26 September 2012, 08:58 GMT
I have been unable to find an ntfs-3g driver that is stable. I am currently running 2010.8.8-1 and that one still crashes regularly. Perhaps the problem does not lie in ntfs-3g but in one of the modules it interacts with, perhaps FUSE?
Comment by Natanji (Natanji) - Wednesday, 26 September 2012, 10:21 GMT
In https://bbs.archlinux.org/viewtopic.php?pid=1147302 a user reported that the problem went away when uninstalling gvfs. Can others try out if removal of gvfs fixes the problem? I sadly need the software that depends on gvfs so I can't.
Comment by Denis (Foks) - Friday, 28 September 2012, 22:48 GMT
I have no gvfs installed and the same issues appear for me too.
Comment by Visa Jokelainen (Viski) - Saturday, 29 September 2012, 11:00 GMT
I haven't got gvfs either, and I've the same problem. The problem might occur during heavy disk operations - I've been editing raw photograps a couple times when the driver buckled up.
Comment by Alex Forencich (alex.forencich) - Saturday, 29 September 2012, 18:47 GMT
It is definitely related to heavy use. I have two partitions mounted and only one of them will randomly break, in many cases during a backup. The other one is hardly ever accessed.
Comment by Denis (Foks) - Thursday, 04 October 2012, 14:46 GMT
May it be related to laptop-mode-tools?
Comment by Denis R. (lezter) - Thursday, 04 October 2012, 15:43 GMT
Still happens with only one my NTFS filesystem out of three. When I mounted it with 'debug' option I've managed to capture part of the log on the first terminal:
<skipped>
DELETE: 75817
FORGET 55921/2086
DELETE: 55921
FORGET 54878/2092
DELETE: 54878
FORGET 18635/25
DELETE: 18635
DELETE: 18634
FORGET 18634/38
fuse internal error: node 18634 not found

How to direct FUSE or ntfs-3g log output to file rather than console?
Comment by Denis (Foks) - Thursday, 11 October 2012, 14:26 GMT Comment by Alex Forencich (alex.forencich) - Thursday, 11 October 2012, 15:39 GMT
Well, I think the problem may be fixed in FUSE, we just need to wait for it to be released or add the patch manually. Commit in question: http://fuse.git.sourceforge.net/git/gitweb.cgi?p=fuse/fuse;a=commit;h=1061a0a2d90148bd2e7f32e1e694399db2dbe087
Comment by Alex Forencich (alex.forencich) - Monday, 15 October 2012, 01:48 GMT
Interestingly, it looks like the patch is in fuse 2.9.2 as it is tagged in the fuse repository, but there isn't a corresponding .tar.gz on sourceforge yet. Very odd.
Comment by Alex Forencich (alex.forencich) - Sunday, 21 October 2012, 20:48 GMT
Fuse 2.9.2 was released some time ago and I went ahead and installed it. I have not had any issues with ntfs dropping out, so as soon as fuse in extra is updated, then this can most likely be closed.

Loading...