Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30529 - [tracker] does not shutdown when not needed by any user session

Attached to Project: Arch Linux
Opened by Fritz Heinrichmeyer (Heinrichmeyer) - Wednesday, 04 July 2012, 07:45 GMT
Last edited by Jan de Groot (JGC) - Thursday, 08 November 2012, 21:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

after logging out of gnome-shell session and clicking restart menu entry in gdm a password dialog pops up:

"System policy prevents stopping the system when other users are logged in"

even if there is no other user logged in.
There is no problem in restarting when i switch to a text console and type <ctrl><alt><del>

Additional info:
* arch linux 64 bit, without testing packages, using gnome-shell 3.4.2, Kernel Linux 3.4.4-2-ARCH, init=/bin/systemd, dropbox
* sorry, i am not shure which package to blame.


Steps to reproduce:
first log out as user, then restart with gdm menu in top right position.

This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 08 November 2012, 21:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in gvfs-1.4.1-2.
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Wednesday, 04 July 2012, 08:02 GMT
sorry i mistyped the title, it should be

Inadequate password dialog when shutting down gnome system.


I don't see a way to edit the title.

Additional info:

the command "users" from a login shell in one of the text consoles apart from the xsession delivers

"(unknown) fritz"

after logging out of gnome-shell and

"fritz fritz"

after logging in in gnome-shell again

whatever, when i do not boot with systemd as init, this bug/error vanishes. Even without systemd, the (unknown) user is visible and somehow the virtual console for X session moves from 7 to 8.

Comment by Matthias Dienstbier (fs4000) - Wednesday, 04 July 2012, 11:52 GMT
It's pulseaudio. It somehow stays running after the logout so the system (probably ConsoleKit) thinks you are still logged in.
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Wednesday, 04 July 2012, 12:13 GMT
Killing pulseaudio from a console after leaving the graphical gnome session really helped ... after logging out the text console of course :-)

The dependency on systemd then was a random effect? Apart from systemd having to do with it or not:

This is an annoying bug when there are users that do know and don't want to know the root password and are no hackers at all.

PS: If someone would be so kind to change the bug report title ...
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Friday, 06 July 2012, 06:36 GMT
Another pulseaudio symptom:

After not beeing able to shutdown and logging in again i have to mute the volume to zero and then raise it again to hear sounds again. This is a major irritation for non technical users.
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Friday, 13 July 2012, 18:29 GMT

Another Problem?

The Xorg console changes from 7 to 8:

Start gnome session, logout, login again --> the virtual console for Xorg now is on 8 and stays there.
Comment by Ionut Biru (wonder) - Friday, 13 July 2012, 18:33 GMT
can't you type who and see what user is logged?
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Saturday, 14 July 2012, 16:45 GMT
Sorry, but now the error is no more reliably reproducible. As far as i remember on last error there was one additional user fritz.
I will post here when i explore a correlation to power save events.

After second login into gnome, "who" shows my login name at tty8 (on first login into gnome on tty7, this change is reliably reproducible). Every additional gnome terminal creates another line, ie:
fritz tty8 2012-07-14 18:26 (:0)
fritz pts/1 2012-07-14 18:29 (:0)

tty8 is the highest tty number i can achieve by loging in/out.

xterm does not create such an entry btw. but i think this is configurable in gnome-terminal settings.
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Tuesday, 17 July 2012, 08:13 GMT
Maybe the effect depends on hardware: the change in vt number only happens at a gigabyte board with ati hd 3200 onboard graphics and ac97 onboard sound. It also could be correlated to linux kernel 3.4.

There is a forum thread about similar observations:

https://bbs.archlinux.org/viewtopic.php?id=105595
Comment by Alexander F Rødseth (xyproto) (trontonic) - Monday, 10 September 2012, 20:55 GMT
Is this still an issue?
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Friday, 14 September 2012, 15:34 GMT
still there, but not always. I use firefox with four application tabs. When i close firefox manually before closing the gnome session it happens rarely.

What then helps is going to a linux-console, typing "some times "pulseaudio --kill" (until there is no more process left), then logging out, then changing to the gdm-session, then shutting down with system menu (top right). At this point shutdown works without further password dialog.
Comment by Jan Steffens (heftig) - Friday, 14 September 2012, 16:02 GMT
Try disabling "run as login shell" in the profile you use in gnome-terminal.
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Friday, 14 September 2012, 16:11 GMT
run as login shell was not enabled.
Comment by Jan Steffens (heftig) - Friday, 14 September 2012, 17:20 GMT
When the issue appears, abort the shutdown attempt and record the output of the following commands, please:

ck-list-sessions
loginctl list-sessions
loginctl show-session X Y Z; X Y Z being the session numbers from "loginctl list-sessions"
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Monday, 05 November 2012, 20:15 GMT
now with gnome-3.6 the problem came again (ck-xxxx commands are gone, i am on a systemd system now)
Following processes survive quitting the session and inhibit a shutdown from the gdm window without a privileged password:

/usr/bin/pulseaudio --start --log-target=syslog
/usr/lib/pulse/gconf-helper
/usr/lib/tracker/tracker-store
/usr/lib/tracker/tracker-miner-fs

every login/logout cycle generates a new pair of tracker processes

Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Wednesday, 07 November 2012, 13:50 GMT
i left my gnome-shell session, tried to reboot (was denied), then i went to tty2.

"loginctl list-sessions" gave 3 sessions (2 6 7).

The attachment shows output of
"loginctl show-session 2 6 7".

After logging in again, i have still session 2 and another session 8.
Comment by Jan Steffens (heftig) - Wednesday, 07 November 2012, 14:29 GMT
Try setting exit-idle-time=0 in /etc/pulse/daemon.conf (don't forget to uncomment). PulseAudio should then exit when the last session of the user is closing.

Otherwise, it hangs around for 20 seconds, which may prevent session closure, at least for a short time.

Now, does it still run after logging out the last user session? Please check if it's actually pulseaudio and not something else. If it does, try "pactl list clients".
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Wednesday, 07 November 2012, 14:44 GMT
still have one more session after quitting, now it is no more pulse but only "tracker-miner-fs". The tracker-miner-fs process is the only one from the old session.

Maybe this should be a tracker bug now or is there a problem with process management in general?
Comment by Jan Steffens (heftig) - Wednesday, 07 November 2012, 14:51 GMT
Seems like a tracker bug. Please send it upstream.
Comment by Fritz Heinrichmeyer (Heinrichmeyer) - Wednesday, 07 November 2012, 16:09 GMT
It looks like there is a relative fresh patch for gvfs addressing this upstream


https://bugzilla.gnome.org/show_bug.cgi?id=681887 tracker bug pointing to

https://bugzilla.gnome.org/show_bug.cgi?id=687074

Loading...