Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#30505 - [libegl] Missing dependency, also need rebuild against libudev

Attached to Project: Arch Linux
Opened by Laurent Carlier (lordheavy) - Sunday, 01 July 2012, 20:00 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 02 July 2012, 08:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Opengl module in kinfocenter fail to load because:
* kcm_opengl.so library depend on libgbm.so, missing dependency
* kcm_opengl.so depends also on libudev.so.0, systemd-tools in core provide libudev.so.1 (rebuild needed)

Additional info:
kdebase-workspace-4.8.4-2 in testing
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 02 July 2012, 08:11 GMT
Reason for closing:  Not a bug
Additional comments about closing:  see the last comment
Comment by Andrea Scarpino (BaSh) - Monday, 02 July 2012, 07:33 GMT
Are you sure? kdebase-workspace doesn't link to udev, kdelibs does.

Also, this is the output of readelf -d on my system with KDE 4.9:

0x0000000000000001 (NEEDED) Shared library: [libkdeui.so.5]
0x0000000000000001 (NEEDED) Shared library: [libQtGui.so.4]
0x0000000000000001 (NEEDED) Shared library: [libX11.so.6]
0x0000000000000001 (NEEDED) Shared library: [libGLESv2.so.2]
0x0000000000000001 (NEEDED) Shared library: [libEGL.so.1]
0x0000000000000001 (NEEDED) Shared library: [libkdecore.so.5]
0x0000000000000001 (NEEDED) Shared library: [libQtCore.so.4]
0x0000000000000001 (NEEDED) Shared library: [libstdc++.so.6]
0x0000000000000001 (NEEDED) Shared library: [libc.so.6]
0x000000000000000e (SONAME) Library soname: [kcm_opengl.so]

Also, I haven't libgbm on my system and the OpenGL module loads fine.
Comment by Laurent Carlier (lordheavy) - Monday, 02 July 2012, 08:02 GMT
Dynamic section at offset 0x1cbe8 contains 41 entries:
Tag Type Name/Value
0x0000000000000001 (NEEDED) Shared library: [libX11-xcb.so.1]
0x0000000000000001 (NEEDED) Shared library: [libxcb-dri2.so.0]
0x0000000000000001 (NEEDED) Shared library: [libxcb-xfixes.so.0]
0x0000000000000001 (NEEDED) Shared library: [libxcb-render.so.0]
0x0000000000000001 (NEEDED) Shared library: [libxcb-shape.so.0]
0x0000000000000001 (NEEDED) Shared library: [libxcb.so.1]
0x0000000000000001 (NEEDED) Shared library: [libgbm.so.1]
0x0000000000000001 (NEEDED) Shared library: [libglapi.so.0]
0x0000000000000001 (NEEDED) Shared library: [libX11.so.6]
0x0000000000000001 (NEEDED) Shared library: [libpthread.so.0]
0x0000000000000001 (NEEDED) Shared library: [libudev.so.0]
0x0000000000000001 (NEEDED) Shared library: [librt.so.1]
0x0000000000000001 (NEEDED) Shared library: [libdl.so.2]
0x0000000000000001 (NEEDED) Shared library: [libdrm.so.2]
0x0000000000000001 (NEEDED) Shared library: [libc.so.6]
0x000000000000000e (SONAME) Library soname: [libEGL.so.1]

So the problem comes from libEGL.so for both issues, so bug must be reassigned.
Comment by Andrea Scarpino (BaSh) - Monday, 02 July 2012, 08:04 GMT
  • Field changed: Summary ([kinfocenter] Missing dependency, also need rebuild against libudev → [libegl] Missing dependency, also need rebuild against libudev)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Category (Packages → Packages: Extra)
  • Field changed: Architecture (All → All)
  • Task reassigned to Andreas Radke (AndyRTR)
Here libEGL.so doesn't link to libgdm, neither to libudev. Anyway, I'm re-assigning this to Andreas
Comment by Laurent Carlier (lordheavy) - Monday, 02 July 2012, 08:11 GMT
OK, the problem is because of old file lying around built from git mesa

Bug report can be closed!

Loading...